Midi-problem and crash in D5

Firstly, great update, congtatz!!

but I’ve ran into 3 problems:

  1. D5 doesn’t recognize my MIDI-keyboard when starting a new project in D5. It works fine when opening D4-projects though. I can’t for my life understand what I am missing since I’m not changing any settings.

  2. I’ve had a bunch of crashes resulting in this message.

Here is the crash log:
2023.5.24 (548.9 KB)

  1. The scrub-shortcut ctrl-space doesn’t work on my Win-computer. I’m not sure if there are is a system command that interferes with it, but nothing happens when pressing that outside of Dorico.


/ Mats :slight_smile:

I believe you might find that Ctrl+Space is mapped to changing keyboard language by default in Windows.

To solve your MIDI keyboard problem, it may be that if the audio engine is crashing, that’s why you’re getting no MIDI input, because MIDI is handled by the audio engine. Do check that the “use WinRT MIDI” option on the Play page of Preferences is disabled (unless your MIDI keyboard connects via Bluetooth).

It looks like the crash in the audio engine is somehow caused by the driver for your Fireface interface – can you make sure you’ve got the latest available drivers installed?

Thanks for your quick response @dspreadbury !

The Play preference solved the Midi problem and a driver update solved the crashes.

After some extensive Googling an searching on my computer I also fund that one of the instances in Microsoft PowerToys also uses the shortcut ctrl+space. After disabling that one everything now works as expected.

Thanks again for a great update!! :heart_eyes: