MIDI problem : triggering a vst (groove agent) with roland SPD20

Hi you all
I connected my spd20 to a USB to midi device (USB UNO )
the computer receives the midi signal : cool
cubase 9 receives the midi signla : cool
when I try groove agent, it doesn’t receive any midi signal …

What could be wrong ?

It would be very kind to help me… I’ve tried so many things : I’m lost

thanks !

Have you tried to add the Midi Monitor to your Midi Inserts on your Groove Agent SE track, so see if anything is arriving at that track?

You may also want to check your Preferences for Midi Filter to ensure that there is no undesired filtering.

In my example below I have filtered all input from Midi Channel 16, so no channel 16 notes arrive at any tracks.

hi , first : thank you
here’s a screenshot

Following your advice , I’ve inserted the midi monitor and enabled the “record on the track” button
There’s now a signal in the monitor (there was none before)
I also tried to filter in the preferences menu as you suggested, without noticeable change

Unfortunately, nothing seems to be working…my groove agent is still mute :frowning:

Thank you for the screen captures.

I shows that your midi connection works and your track is getting the notes from your SPD 20.

But you have a very confusing project setup, which is difficult to investigate. It might be easier if you start over with a new simple Project.

  • Create a new Empty project
  • Add 1 instrument track for Groove Agent SE
  • Do not add any other tracks
  • Set the track input to your USB Uno Interface
  • Load the Midi Monitor into the Midi Insert
  • Load the drumkit “R&B Kit 01” into Groove Agent SE
  • Play notes on your SPD20
  • Do you get sound now?

If you still don’t get sound, upload screen captures

  • Your Project window
  • Your Groove Agent SE Window

Everything done…still no sound


Try enable monitoring " little speaker icon on the track, next to record enable".
If that does not work, try also enabling midi thru in preferences.


it’s working ! midi thru rules :wink:

thank you soooo much !

1 Like