MIDI problem (very strange behaviour!) WITH VIDEO LINK DEMO

EDIT: Here is the video demonstrating exactly what is happening: http://youtu.be/GPQlmEClUWs

Hi there,

I am using cubase 7.5.3 with motu midi express 128 and fireface 800. I also have Presonus Faderport. The system is K2600 i7 with gigabyte x68 board, 16 gbyte ram windows 64 bit 7. I also have a UAD quad installed.

Here is the problem:

  • Firstly, I didn’t have this problem before, and the install is not fresh, so something triggered it I don’t know what. No new hardware though, everything is the same.
  • The problem is that midi is either completely lost or mostly starts to act VERY strange after 5-10 minutes of usage. Lags of more than 4-5 seconds start to happen and all the notes are almost played all at once after I play something on my midi outputting devices (korg kronos, korg microkorg or my yamaha p80 piano…I use all these as my controllers). Sometimes, it goes further and the whole midi connection seems to be lost between MOTU express 128 and cubase…

I tried:

  • Reinstalling midi driver for motu
  • Disabling power saving options of usb port that motu is using
  • Resetting preferences of cubase
  • Using only windows midi and also tried using only emulated
  • Tried changing system stamp and the other way around
  • Tried disabling and enabling vst guard


    Anybody exprienced something like this before???


    I am not 100% sure, its only a “feeling” or guess but I have been using cubase for 15-20 years and to me it feels like cubase is being bombarded with either a lot of midi information that it can’t handle, or midi messages that it cannot interprete…
    However, even if this is the case, I don’t know what is causing this…

I have experienced problems with lag before - in real time and more so when recording. However I overcame this by no longer using ASIO Generic Low Latency drive and using ASIO 4 All. Hope this helps.

thanks for help but I am already using native rme fireface asio driver :frowning:

Do you have a midi loop back from a keyboard into Cubase again? I created a midi loop once and it locked up everything including Cubase and the OS! What do the midi I/O lights look like on the transport bar?

Another thing to do would be to try using another app instead of Cubase. For example, does MidiOX work? Perhaps try to use Media Player to play a midi file? I don’t know any free apps that send midi but there must be some you can test with.

And, something I did the other day to clear out my MIDI device drivers was to follow this web page, primarily to speed up Cubase startup but it may help you in distilling the problem down:

Mike.

New information: When I STOP the transport it gradually goes back to normal…when I PLAY the track…the lags of 3-4 seconds and more start to happen!..then I stop the transport…and it goes down…Now that you mentioned, I remember that I installed some sort of midi routing software once…and the driver is disabled but its still installed…I Will try and uninstall it and see what happens…thanks…I will report back

Here is the exact problem http://youtu.be/GPQlmEClUWs

I have captured my screen + my midi keyboard using webcam, so that you can see what is going on exactly…

I can’t see that vid because my browser is playing up - flash block and flash player don’t like each other!

Anyway, I recall that I installed a virtual midi port or two a while back and I had to remove them both because it caused untold problems! So, if you haven’t narrowed it down check if it’s that yet then it’s a strong possibility.

Mike.

I removed the virtual midi driver and reinstalled cubase just to make sure…I will report back…Its intermittent so I have to wait and see if it will happen again…thanks a lot

"Plug-in " are my first thought that couse this weird behavior.


Sometimes a specific plugin couse extreme latency behavior.
Disable all plugins and see if that solves the issue?
If that is the case then reactivate one by one until the issue come back.
Then you know what specific plugin couse this issue.

Best Regards
Freddie

I just installed a MIDI Express XT USB to an iMac running Cubase 7.5. I immediately had (have) similar issues. Random notes being played while recording, notes being delayed and sustained. The problem does not occur in Garage Band so I assume it’s a connection issue or setting in Cubase. I sent Steinberg a tech support request as I have just upgraded to 7.5 so I am still in warranty. I’ll let you know if I come across a solution.

Sounds very buggy?
If I were you I would return the MOTU MIDI Express XT and get a refund.

Best Regards
Freddie

I would like to hear of an overhaul of midi in Cubase because I actually think it’s Cubase that’s pretty buggy particularly with external midi interfaces… I’ve got various different interfaces including direct USB and when I’m using ProTools I don’t get any problems but when I use Cubase I get degrading midi reliability the longer I use a single session. Things like hanging notes when auditioning a note in the piano editor, sticking notes while playing, bad timing with notes being obviously spread out, midi chasing flakey, etc. Sometimes Cubase loses contact with the midi interface and that means a restart. Its not so bad that I can’t work, but it does mean that I can’t let my attention drop because I can’t be sure if a midi glitch is my playing/recording or caused by Cubase. I tend to record to audio or a VSTi as quick as I can - unlike the old days when I would be mixing with hardware midi instruments playing in the mix. So, I say its time for Steinberg to look towards this part of the app and give it a good spring clean!

Mike.

Could that be related to the MTC bug in Cubase 7.5.30 ?
If you have any midi time clock setup, try disabling it.