MIDI Program Changes not working correctly in Cubase 9.5

Hi there,

I’ve been using Cubase for the last 20 something years. I’m using it everywhere, in the studio as well as on stage with my band. I’ve helped and installed many local and international artists on Steinberg/RME solutions, even wrote software with Steinberg’s SDK. Let’s just say I’m not a newbie! :laughing:

Recently, after MANY years of faithful services, I’ve decided to upgrade my good old Cubase 5 (32bit) to 9.5 (64bit) for my live show. My session is simple: All audio tracks (around 10 of them), no plugins on, except for Kontakt 5 which is used on a few songs for triggering custom synth sounds (again, sampled, no multi-layer, scripts or anything, kept it trivial!).

I also have a 3 MIDI tracks which controls all our MIDI devices on stage (sending MIDI Program changes ONLY) so we don’t have to bother searching for patches on stage. Everything’s automated.

Now, this setup was working perfectly with Cubase 5. My Kontakt 5 behaves like it should on MIDI program changes, our Kemper guitar amp is switching perfect too. Now, enter Cubase 9.5! Everything starts behaving strangely. Kontakt 5 program changes works most of the time, but not always. Same for the Kemper amp, it is mostly correct but sometimes, the program changes are out of whack…

Now, is it possible that Cubase 9.x has some MIDI bugs? I mean, both VSTi and external devices behaving strangely? Can’t be a coincidence? I had the same problems with Cubase 8.x which kept me on version 5 (and that is still the case, can’t depend on 9.5).

I’ve tempered with the MIDI chase settings, no changes really, Cubase 9.5 still has problems with program changes.

I am condoned to Cubase 5 32bit for eternity? I have a recent i7 laptop with 16gigs of RAM which I can’t use because 32bit is limited to 4gigs only.

Please advice, thanks in advance.

There’s one thing I forgot to mention in my last post: I am using the Arranger track for sequencing my songs’ order in my show. I made one arranger “region” per song and this enables us to program set lists with simple drag and drop.

All MIDI program changes are one bar preceding the start of each songs so when Cubase gets to the end of one song, it locates the cursor to the next song on the arrange list and chases back the MIDI programs.

Once again, works perfectly in version 5.0. Thanks.

No news from the authorities? Need more info? Reproducing the bug is simple. Just create a few regions within an Arranger track and precede those regions with MIDI program changes. You’ll see, they’re off most of the time.

Preceding? Wouldn’t they have to be before the end of the preceding event? (they are called events, not regions in Cubase.)

And yes, your description isn’t specific enough, maybe that’s why you’re not getting responses.

I have attached to this thread an image showing my setup for clarity. Like stated before, it is real simple: I have a few arranger “blocks” (or call it what ever you want) that are songs in my show. We use the Arranger window to select the order of our set list, it is really useful for last minute changes and such. Each song has a repeat count of one and the “Pause after Repeats” option. So we play “Song A”, then at the end of that song, Cubase locates to the next song in the Arranger List and stops/pauses there until we press play again.

Now, notice that there is some MIDI events PRECEDING (time wise) each Song blocks in the attached image. Those are controlling our MIDI devices on stage. Cubase chases back the MIDI programs when it locates the next Arranger block. So, say we’re done playing “Song A”, Cubase locates the cursor to the beginning of “Song B” and chases the MIDI program changes contained in the MIDI event preceding the song.

This works wonders in Cubase 5 (32bit) but troublesome in Cubase 9.5 (64bit). The MIDI program changes are being sent but with the wrong patch number. The bug applies to external and VSTi instruments as well. This renders our session unusable as the band members are obviously dependent of the correct patch being loaded in our respective machines/instruments.

I can provide an example session to you guys if you are willing to investigate further.

A pic of your screen is not an example session, plus it’s of Cubase 5, not 9.5, please, return to your developer roots :wink: and provide the salient troubleshooting details.

(It sounds like a chasing issue, fwiw.)

I know that a pic is not an example session, I provided it for you to understand what is going on as you requested more details. I can provide a Cubase 5, Cubase 8, Cubase 9.5 and Nuendo 8.2 if you’d like. As for being salient, well, I guess 3 pages worth of explanation here is pretty the best I can do. What more do you want? Pardon my lack of patience here but I’ve been fighting this bug for the last 3 years and nothing as been done about it. I bought 3 versions of Cubase thinking it would’ve been fixed, but NOPE.

PS: I attached a Nuendo 8.2.10 session of this project. Please forward it to the Steinberg authorities.
MIDI Chase Bug.zip (20.8 KB)

This: https://www.steinberg.net/forums/viewtopic.php?f=253&t=107133

I tried the project and the program changes worked as expected.

Try to let the parts with the program changes overlap the beginning of the arranger parts by sizing them.

Hi Werner. First, thank you for pitching in, it is greatly appreciated.

Usually, this is how I do my MIDI program changes, the MIDI overlaps (and continues) through the Arranger region. This example project was just to show you guys how my session was working. Tonight, I’m gonna use the real-world scenario session and will post the result here. I’ll try to reproduce the bug and capture a GIF out of it.

OK, I was able to reproduce the bug and “gif” captured it.

The scenario: We are playing the end of the “Subdivisions” Arranger block. The next cued song/block is “Tom Sawyer”.

Cubase 5 plays until the end, then locates to the start of “Tom Sawyer”, sends the MIDI program change to Kontakt, all is peachy.

Cubase 9.5 does pretty much the same, but the program change is not sent (or erroneous). Sometimes, it even changes to “0” (the first Kontakt empty patch) Even more bizarre, once this bug happened, Kontakt doesn’t receive MIDI program changes no more. Where ever I locate my cursor, nothing chases, no program changes are being sent.

I can provide the session if you’d like to investigate further. Thanks in advance.


If you post it- I’ll have a look at it, then delete it (since it has your work in it.) A lot has changed since Cubase 5. It could be as simple as a pref not being set, or possibly corrupted prefs. If this a bug it will be reported.

I’ll send it to you via private message (if possible) and if not, I’ll post it here. I already double checked the MIDI prefs, tried changing the “Never Reset Chased Controllers”. Didn’t change the bug behavior. (See attached picture)

I just made an experiment, loaded a Kontakt script which is a MIDI monitor. The patch changes are perfect in C5 and are sometimes skipped in C9.5 (using the “Never Reset” ticked). My suspicions were true: I’m receiving MIDI program change #1 for “Tom Sawyer” when I’m supposed to receive #9. So, Kontakt is 100% ruled out of the bug.

Thanks for your support.

I got the project, and the pic of your prefs is helpful.

  1. Before my doing anything can you please rule out corrupt prefs by following this:
    https://www.steinberg.net/nc/en/support/knowledgebase_new/show_details/kb_show/troubleshooting-instructions-for-cubase-nuendo-and-sequel-on-mac#preferences

  2. There are two Kontakt instrument tracks. Which one shows the problem?

I have done a bit of clicking on arranger events, sending the cursor to it’s place:
Program changes are being sent, and so far, they match what I am seeing inside the corresponding midi parts. (I use the list editor, btw). For example, in Arranger Chain <NVM Show 35th MP> if I hit , Kontakt receives program change 1 on the drum track, and p.c. 9 on the Keys track.

(My next chance to look at this will be tomorrow UMT -6 time. )

  1. Before my doing anything can you please rule out corrupt prefs by following this:
    https://www.steinberg.net/nc/en/support/knowledgebase_new/show_details/kb_show/troubleshooting-instructions-for-cubase-nuendo-and-sequel-on-mac#preferences >

Yes, will do, just to make sure.

  1. There are two Kontakt instrument tracks. Which one shows the problem?

Oh sorry, my bad. Look in the “Instruments” folder, there’s a “Keys Kontakt”. That’s the one I spotted but the two exhibits the same behavior. The best way to reproduce the problem is to play the end of “Subdivisons” which leads into “Tom Sawyer”. “Tom” doesn’t get the correct patch change (that should be #9).

I have done a bit of clicking on arranger events, sending the cursor to it’s place:
Program changes are being sent, and so far, they match what I am seeing inside the corresponding midi parts. (I use the list editor, btw). For example, in Arranger Chain <NVM Show 35th MP> if I hit , Kontakt receives program change 1 on the drum track, and p.c. 9 on the Keys track.

Yes, looks like the bug doesn’t happen when relocating the cursor using the Arranger drop-down menu. Actually, this saved my life 2 weeks ago in a concert! We started “Tom” but the sound was completely off! Just selected “Tom” again in the menu and it was fixed (God thanks). May I suggest to play endings of songs (like shown in the previous GIF) and verify is the next patch number is correctly selected in Kontakt? “Subdivisions” into “Tom Sawyer” is the one that I found today but it happened plenty of other times, on all the other MIDI devices (VSTis and externals).

Thanks again,

Hi again !

I chimed in here, because I know the problem, because my workflow is the same, when I play live (using the arranger track with my Roland VG99).
I was unable to nail it down, even with the source code before my eyes.
So it would be a good idea, if You could send me a copy of the project as PM as well. For my projects I actually put an extra program change a few ticks after the section start as safety…
I think, the program sometimes chases to a wrong position (position zero + the time the arranger track has played in total, but not the the time, where the section starts). But it is not consistent.

Ah hah! Werner, I’ll PM you what he sent me now.


(pm sent)

Hi again Werner! Finally, someone acknowledges the bug after all this time! :slight_smile: Thanks for letting me know I wasn’t going insane! :laughing:

I did try to “delay” the program change by a few ticks left and right, didn’t do nothing. (Maybe I didn’t nudged it enough?) I’ll give it another try tonight when I get home.

Thanks to Steve as well for his continuous support, I know I’ve been a little on the edge here, sorry about that.

Hi Marc,
I could consistently reproduce this bug with your project. The jump from “Distant Early” to “The Pass” produces a wrong prg change.
It only occurs in the mode “Stop after looping”.
I hopefully fixed this problem now. The bad news is, that the fix will appear in Cubase 10, because the next 9.5 update is allready “closed”.
Thanks for Your patience.
Werner

Hi Werner,

I’m glad that you could reproduce the bug for you to fix it. Another fault “jump” was the aforementioned switch from “Subdivisions” to “Tom Sawyer” (Instruments Folder, “Keys Kontakt” Track) Just in case you are looking for another one to test. I understand that the fix will be included in Cubase 10. Please don’t delay too much! :wink: :smiley:

Thanks for taking the time to troubleshoot this bug, I might be able to FINALLY use my laptop’s full RAM potential! Yay! :smiley: