MIDI quantize brings all prior events to the start

Say I record 18 bars of MIDI, stretch the start-point of that MIDI event to 2 bars later in time (now it is a 16 bar event, but it has 2 bars of MIDI data that sit before it, they should not be heard). In the bottom-screen MIDI editor, if I select all then press Q (quantizing at 1/16 granularity), all events in that 2 bars of MIDI data that sit prior to what I want to hear get pulled to the start of the 16 bar event. I don’t think this behaviour is consistent in 10.0.15, it shouldn’t do that - if anything, the first 2 bars should have also been quantized according to normal quantizing laws, which is how it should usually work right?


Could you try in Cubase Safe Start Mode, please?

I just restart Cubase 10 and it behaves differently, usually the way we think it is meant to. Could there be perhaps some race-condition that is causing some fundamentals of the physics laws in Cubase to startup corrupted?


You can start Cubase in Cubase Safe Start Mode, or trash Cubase preferences to get the Factory settings.

I found the culprit for most, if not all, the weird problems I’d been seeing: I’d unquarantined(?) Bluearp VST atsome point, removing it sees a well functioning Cubase.

I’ve seen this behaviour for ages, in many different versions of cubase. I just select what’s in the current part, not before it, and quantize that. That is a pain tho, so any suggestions for solutions are great. I don’t believe I have the Bluearp vst.

I’ll try safe start mode and see if that helps.