MIDI questions from a previous Sonar user

Hi There

I’ve recently bought Cubase 9 Pro as a move from Sonar X2, I’d gotten a bit sick of Sonar which seemed to be quite unstable on my computer and their video support was horrendous.

That said I really liked the MIDI features on there, as a composer I tend to work with VST’s a lot and once I’d gotten my templates set up in Cubase I started to try to work with MIDI in the same way that I used to work in Sonar, but I came up with a few problems, if anyone could answer a couple of my questions below it would be greatly appreciated.

When writing large scores in Sonar, i.e. with 50+ MIDI tracks, I generally used to open the piano roll and write in a few ideas while displaying all the tracks to a section (i.e. string section in the orchestra). In Sonar this was a simple case of hilighting the tracks and pressing Alt-3.
It seems like I can’t do that in Cubase, as I have to manually add an empty MIDI region and then double click on that MIDI region to open the piano roll. Is there no other way of doing this? i.e. some shortcut that would immediately open the piano roll? It’s pretty frustrating having to do this on 50+ tracks!

Also regarding MIDI regions, I don’t understand why it doesn’t automatically extend the region for all of the notes that I write in. I can create new notes but once it goes outside of the region that I manually created, they are muted and I have to drag the region over in order for those notes to play. This seems quite counter productive to me, as in Sonar I’d just write as many notes as I needed and they would just work straight away, regardless of where in the project they were, it would extend the region for me automatically.

Also, working with 4 screens, I’ve managed to figure out how to display my console on a seperate screen, and my piano roll on another screen, however, every time I undo something in the main project screen it would close my piano roll window. Is this a bug?

MIDI just doesn’t seem to work in the way I’m used to on Sonar, and it’s pretty frustrating not knowing how to get stuff to work, but I’m sure I’ll get there with a little help.


Hi and welcome,

In Cubase MIDI data are not based on MIDI Track, but MIDI Parts. You always have to make a MIDI Part, where do you place the MIDI Events then. Just add some empty MIDI Parts to your template. Would this work to you?

It’s just different approach, different workflow.

The “bug” you described is linked with this. If you remove a MIDI Part you have opened in the Key Editor, the Key Editor window closes. Because there is nothing to show, the MIDI Part doesn’t exists anymore, and the Key Editor (actually all MIDI Editors in Cubase) is based on the MIDI Part, not the MIDI Track.

I hope, this clarifies it for you a bit.

Hi Martin

Thanks a lot for the reply, that makes sense, I guess I just have to learn the new way of doing things then!

I have three more questions for you if you wouldn’t mind answering them!

On sonar there was an option to change the length of the note you were drawing depending on whatever the length of the last note you ‘touched’ was. This meant if you drew a note, changed it to a crochet length, then the next note you drew would also be that length. I found this really helpful in speeding up the writing process.

When drawing notes in the piano roll, the note doesn’t currently make a sound, until you play it back. I’m pretty sure it did at one point but it stopped. Is there some sort of option to make this happen again? (using a mix of Kontakt & EWQL libraries).

Colours on the piano roll, are these assignable seperate to the project track colours, at the moment they are all the same which gets confusing when displaying a lot of tracks at once. Changing the colour in the main project window doesn’t change the colour in the piano roll.

Thanks again for your help!


  1. No sorry. It always used the default length.

  2. Double check the Feedback is enabled (speaker button in the top left corner of the editor).

  3. Yes, there is the color drop down menu in the toolbar. If not, right click on the tool bar and enable it. Here you can set the color scheme.