Midi Rec Problems

Hi, I have a problem with my Midi recording. Usually, when I record b.e. a chord as a Midi, and then I add another chord to it, the second one shows in the same pattern of the first chord. Strangely, since today, if I follow this process, the second one shows in a different pattern which overlaps with the first one and that’s very annoying. I don’t know how to change these settings , I want to have them in a unique pattern. Can you please help me?


What do you mean by “pattern”, please? Maybe a screenshot would help here.

How do you record the chord? Do you record in the Project window or in the Editor?

As you can see in the screenshot I firstly recorded a chord, then I opened that section in the editor and tried to add another chord next to it in the same section (always by recording or background recording) but, instead of putting it in the same section, it creates a different section. This never happened before, I hope that the problem is more clear now.
Thank you very much for the help.

Also this is a video that’s more clear but I don’t know if you can see it.


I expect, there was no MIDI Part before. So you hit Record and record the MIDI data. Cubase created the new MIDI Part.

We call this MIDI Part.

To record to already existing MIDI Part, open the Key Editor. In the Key Editor, enable the Record in Editor option. Then start the recording by using a Key Command or from any hardware MIDI Remote Device. The trick is, that the focus has to stay in the Key Editor window. If you click on the Transport Panel, the focus moves back to the Project window, so you don’t record in the editor anymore. You record to the Project window.

Or change the Record Mode in the Set up MIDI Record Modes > Linear and Cycle MIDI Recording. Set it to Merge.

The best record mode has to be stacked. it keeps the old but you don’t hear it and at the end you’ve got several ideas you can cut and shut. Set the key editor to open up in a separate window (the way it should always be) so the focus doesn’t change on you all the time. It’s been functioning this way for a long time now, I’m surprised you haven’t had a mired of problems that being the case.


I disagree. It depends on your use case.

For example, if you are recording drums (first Bass Drum, then Snare, then Hi-Hat), the stacked mode doesn’t make sense at all.

There are different modes for different use cases. Luckily, Cubase is very flexible.

Yeah thats true Martrin, I guess i wouldn’t/must not overdub that much.