Midi-Record double notes problem

Here’s what I’ve done to try to streamline the midi-live record process. I changed the latency compensation to 6ms, which as you can see, works fine. I however, cannot for the life of me figure out where dorico’s midi port setups are. I went to the cog and save endpoint section, changed it to one port only, and still I’m getting double notes inputted as I’m recording. Here’s a screenshot.

Any ideas how to debug this? It’s very strange, I must have accidentally clicked on some setting to conjure up this problem, because it was fine before.

Thanks in advance.

Do you have a ‘Local on/off’ switch on your keyboard? If so, try setting ‘Local’ to ‘Off’.

Ah, yes. That was the problem. Thank you!
I turned Local off as recommended in my keyboard manual, which for me was demo+metronome+C6. Thanks.