Midi record problem vst instrument, another try

Hi all,

I just installed Cubase 6.5 and I noticed some strange behavior I never had before with Cubase 6.0. If I record a MIDI track with a VST plugin, b.e. Retrologue, for a couple of bars (click on), and just play a note on the first beat, and play back the track, the note won’t start on the first beat, but is shifted to the left (instead of starting on 1.1.1.0 , the note starts consequently on -2.4.4.104, so it won’t play back. But If I record an external instrument on another MIDI track, the note just starts at 1.1.1.0. I don’t use track delay, so I don’t know what’s happening. I already used the System Time Stamp for "Windows MIDI’ inputs, but that doesn’t work. Thanks for any help on this subject.

Regards,

Mark Hofland

Search for info in the forum on similar threads.

To make a long story short: you, like many others, are having a problem Steinberg is not going to fix. If it becomes annoying enough for you, go and change your sequencer.

At what ASIO buffersize are you working and what’s the samplerate of the project?
And are you using a Windows MIDI device or Direct Music MIDI device?

Hi Niles,

ASIO buffer is 512 samples, running 48 Khz, and using Windows MIDI. It is still strange, If I record my Motif on a MIDI channel, I don’t have a problem, but all VST instruments give the same starting point at -2.4.4.50, and at -4.4.2.27 some sysex info. The strange thing is, when I auto quantize a MIDI channel with a VST instrument while recording, the problem is gone, the note just starts at 1.1.1.0, and still some sysex at -4.4.2.27.

Is only the first note of a VSTi played event early?
What happens when you play a VSTi at a lower buffersize (256 or even 128), is the note just as early as working on 512?

For the sysex, does your controller send Sysex data? Did you enable the Sysex filter (Preferences -> MIDI -> MIDI Filter -> Sysex)

Buffer size is a little high. Is there any specific reason to work at 48kHz? If you change that does the note placement alter?
Don’t listen too much to empty rhetoric about bugs. Never helps, just puts a negative spin on the thread.
Don’t let them depress you further. :mrgreen: