Midi recorded slightly early (20 ticks)

Hi everyone !

I’m having a really annoying problem with midi recording : Midi notes are recorded about 20 ticks early. It might not sound like somethign important, 20 ticks, but when you record melody lines that swing, or drums, it becomes impossible to record a track without tweaking all the midi notes afterwards.

I’ve checked pretty much everything, and tried everything (I also searched the forums as well )

  1. Use System Time Stamp (on both Windows Midi and Direct Music)
  2. Ignore midi port filter, and emulated drivers
  3. Delay Compensation
  4. Adjusting for Latency (currently 6ms)
  5. Reinstalling Device Midi Drivers
  6. Updating Sound Card Drivers

I’m pretty much stuck, now. I’ve run out of ideas.

One last thing : I noticed that I could increase this 20 ticks shift by increasing my buffer. Nevertheless, It’s not possible to reduce it more, and even at the smallest buffer possible, I have shifted midi notes after recording. So it’s related, but still, buffer is not the answer.

Thx everyone !

Just on a whim.

Can you try unplugging EVERY MIDI OUT/THRU

and simply use 1 MIDI IN ?

This was answered years ago in the old forum but I can not seem to find the archive - in fact - I was having that very problem.

I think it was something about my MIDI signal… It has been years and at my old age of 40 - memory is the first thing to go. . . :mrgreen:

Thx for your reply, old man ^^.
It seems I’ve finally found something which works, thanks to you ! I managed to record my first track perfectly sync without tweaking midi notes… Thank you !
But…
I can’t hear what i am playing while i’m playing it. That’s a bit annoying, and I don’t manage to find a way. I’ve to playback after the recording to hear what it sounds like. Not so cool…

Any idea, Alzheimer friend ? ^^

Thank you again !

PS : one last question : Do you think my sound card is responsible for this (a pretty old M Audio Audiophile 24-96) ?

I think many of the midi issues are caused by timing errors in the sound card drivers and the system in general. On my previous rig, I had to update a motherboard driver in order to fix correct timing.

Aah now I remember. EXACTLY !

It was as the previous poster said - timing issues getting sound out of the same exact instrument you are recording from.


My McGyuvered solution was to use a VSTi so I can hear myself play (F-11) even a basic piano will let you feel as you are playing. Then after recording you can then set your keyboard as the output.

Same problem I had on the Delta 1010LT and a MicroKORG


NOTE: Also Re-CHeck your ASIO settings to verify it says M-AUDIO ASIO and not the other ASIO choices (I cant verify the exact wording because the C6 setup is down the hall from my computer room and that long walk would do me in at my age)

Thx all for your replies.

I updated my motherboard / chipset drivers, but it didn’t change anything.

To McGuyver/Alzheimer-man : I already use almost exclusively VST. And my main problem now is that with the midi thru unchecked, I don’t manage to have direct sound from any midi channel. It seems that midi notes aren’t sent to the vst while recording. I keep trying to activate monitoring anywhere I find some monitoring options, but nothing’s working for now.
But at least, I begin to understand where my problems are coming from.
Do you think M-Audio is kind of a cursed brand ? ^^
And I also got a KORG (K61), by the way ^^. But since deactivating midi thru makes everything go round, I really think my sound card is responsible…
Sould I buy a new one ? It wouldn’t really be a problem, but I just want to be sure that my problem will be solved :p.

“Adjusting for Latency (currently 6ms)”

How are you doing that?

Hippo

mm, I might not be clear (i’m french, it’s kind of difficult to explain these kind of technical stuff).
All I wanted to say is that I have currently sized my buffer so that I have 6 ms latency. Sorry if it doesn’t mean that, It’s something I saw on another forum, I thought it was about latency and buffer size.

I fixed the problem by physically removing all MIDI cables.
The only MIDI cable I have now are OUTS from my equipment - no ins and no thru’s.

I managed that by adding a 4x4 midi interface.

Seems ANY thru or IN caused the problem to resurface.


It was only a work around and I have not heard my MicroKORG since then (years ago)

But - The timing problems went away - along with a few other MIDI related problems (program changes, stuck notes, etc)


When I had the problem I was using an intel Quad core CPU as well and a Gigabyte motherboard and an M-Audio 1010LT. Seems we have at least 66% of the same base hardware family from that. Maybe it was just a fluke hardware combination.

mm, my problem is that I already have no midi cables plugged in my audio… My Korg K61 is usb, my CC121 too, and my BCF2000 as well (I know, not very pro, but you do with what you can pay :p).
I have no midi in, no out and no thru…
And my K61 is the only one to be in the “all midi input”, so no conflicts here.
Again, if I deactivate “Midi Thru actif” in “preferences / MIDI”, no more shifted midi notes, but no more “hearing-midi-while-recording” either :confused:
Ah, i’m sure we are close, it’s so frustrating !

agree. I will try to get the problem back again tomorrow to see what fixed it.

Thank you very much, that’s very kind of you, but don’t mess up too much with your settings :p. I would really feel guilty to bring it back from the dead ^^.

Do you have any midi inputs that you can use? This sounds like a usb chip problem maybe.

This used to be a problem in older Cubase versions and mostly involved usb chipsets so looking at the old Forum archive may throw up an answer.
Look also at your Windows Device Manager and try to find the make of usb chipset, look that up and see if there are any driver solutions (to this problem) on the net.
I forget whether it was a goody or a baddie but Texas Instruments comes to mind here.
At worst you may have to buy a new PCI usb card which might solve the problem.

I plugged my korg K61 in midi, just to test. Nothing changed, exactly the same problem. Nevertheless, now that you mention it, I remember that when I was on Windows XP, my webcam and my Korg K61 had some usb conflicts. Nothing like this on 7, but maybe it’s juste because it’s not mentionned.
Anyway, I need au new PCI usb card, so, wether it solves the problem or not, it won’t be a waste of money ^^.

I could not get this problem to resurface when I loaded up C6 on my old hardware.

But since that time I have upgraded the motherboard BIOS and cut my USB usage from about 6 items to 3 (cc121, Midiman 4x4 and C6 dongle).


The problem did me a BIG favor years ago… it FORCED me to move away from all outboard synths to 100% VST ‘s which was the best thing I ever din’ done. :laughing:

Thank you a lot for everything. Since you were not able to get this problem to resurface, I think we can assume I have some hardware problem… I’ll try to change my audio card some day…

Thx for everything

No problem. M-Audio cards have a lifetime warranty.

Maybe its time to put that to use.

STIENBERG. ADDRESS THIS FLAW TO MIDI RECORDING!!!

You managed to dig up two threads from nearly a year ago that you were not involved in.
( http://www.steinberg.net/forum/viewtopic.php?f=19&t=8852 )

Do you have a problem or are you only seeking attention?

What flaw?

Different drivers, different timestamps.

It’s manufacturer specific.