Midi Recording ahead of the beat!! Please help!!

Hello everyone,

I’m working on a VST heavy midi project and it seems any new midi I add is being recorded almost a full 16th note earlier than I play it! So for example I’ll play a drum part, when I record it sound perfectly in time with the click and the rest of my tracks, yet when I playback the recorded track it will sound (and look) early against the grid. So to me, Cubase is recording my midi earlier than its actually played, so (guessing here) it seems that the midi tracks are not following plugin delay compensation or something because its impossible to record something before its happens. But whats weird is this “early recording” happens both with “constrain Delay Compensation” on or off, using either instrument racks or tracks, both steinbergs own synths or 3rd party synths!

Here are my VST audio settings if it helps:
Input latency: 11.833ms
Output latency: 7.229ms
ASIO-Guard Latency: 0.000ms
HW Sample rate: 48k
HW Pull up/Down: Off
Audio priority: Normal
Multi processing: enabled
ASIO-GUARD: not enabled
Disk Preload: 2 seconds
Adjust for record latency: not enabled

My interface is at a buffer of 256.

When I play any midi notes, I do not hear any noticeable latency between when I press the key and when I hear the sound, so its not like I’m trying to compensate for a large buffer size when recording, and even if I was that would cause the midi to be recorded late, not early correct? Could this have anything to do with Cubase plugin delay compensation? Like I said, I’ve tried recording with both “constrain Delay Compensation” on and off and it doesn’t seem to make a difference.

Any hep would be GREATLY appreciated as this is really becoming a problem!! Thanks in advance for any help you can provide.

Do you have any plugs on the Master/Stereo Out?
And or,
Try using “system time stamp” in the midi setup dialogue.

“Adjust for record latency: not enabled”

I would try enable this on the track - it adjust recording later according to set latency.

Depending on tempo, how much in musical unit that become - but could very well be a 16th note with roundtrip latency of 15ms as you have.

I experiemented a bit with this, and created two midi tracks, one enabled latency the other not.
Then you can see side by side what fits better.

Thank you both for your help! Turning on the “AISO Latency Compensation” button in the track seems to have solved the problem when in record mode which is GREAT, however it seems the AISO Latency compensation button seems to only work when you record with record mode, and I personally always use retrospective record for my midi all the time, and when I use retrospective record, the data is still early! GRRRR!!! :cry:

I’ve tried searching the manual for “system time stamp” in the manual and cannot find anything on the subject, nor can I find this “midi setup dialogue.” Can someone point me to where this option is located? Maybe its a PC vs Mac thing?

I do have some plugins on my master fader, so I’ve removed them for the time being and still when I use retrospective record with AISO latency compensation on (or off for that matter) the retrospective recorded material is still early. Perhaps this is a bug? Should I do a new post in the bug sub forum? (not sure of the rules on that)

The System Time Stamp check box can be found in
(Devices/Device Setup/Midi Port Setup)

Wow!! I do not see that option at all!! Attached is a screenshot of what I see:

Windows only option.

Sorry for the wild goose chase…

I don’t know whether you have seen this? It might help.

http://www.soundonsound.com/sos/dec07/articles/cubasetech_1207.htm

Did u try this?:


Also, on the MIDI track up by the pan is there a little control that lets you slip the track forward or backwards relative to when u actually recorded it?

Yes, I’ve turned on the “AISO Latency Compenstion” on the track, if that is what you are referring to, and when I actually use the record button to record my midi its now in time! However, if I play on the same track and use the retrospective record, its captured early again! I actually never use the record button for midi, and always use retrospective record, so this is a big bummer for me! I’m wondering if its indeed a bug.

Of course I was manually adjusting after the fact by dragging the notes, but I never know how much to actually adjust and so my performance is technically lost. I guess I’ll have to experiment with that slider you mentioned, however I fear that the amount that is captured early will change, as I do not experience this problem when I start a new session, but somewhere as I’m working it pops up - probably some specific plugin or VST instruments causes too much latency.

Bottom line though, if AISO Latency Compensation fixes this problem with recorded tracks, why doesn’t it work with retrospectively recorded tracks?

edit: I can confirm this behavior by recording (with AISO Latency compensation on) and then when its done ALSO capture the track as recording (so its captured the exact same recording). The captured midi will jump ahead of the recorded midi, which in theory they should double exactly, right?

Sorry, actually I meant the “MIDI Delay” control, page 450 of the manual.

If the earliness is constant from take to take, you could dial in a delay. I think that may just affect the playback timing though, not the actual position on the track, it’s been a while since I looked at it.

Maybe there’s something in the logical editor that could shift all your MIDI tracks for you …

… if there’s no real fix that you find, and if the “earliness” is not random from track to track/take to take.

Hope that helps at least a bit, sorry I don’t know anything about retrospective record …