MIDI Recording Delay

Hey everyone,

I’m struggling to record within Dorico. While it seems to be recording exactly what I’m playing the sound is delayed from when I press the key which messes me up while trying to perform to the click track. I’ve lowered the buffer size as low as it will go and set the input latency to 0ms. Any advice for this situation? I’m inexperienced with this way of working, any tips would be appreciated.

This may not be the best solution for you, but I always turn off MIDI Thru and use the sounds built into my keyboard. I just use the computer for the metronome.

Hi Scott, I use Windows 10 v1903 and have ASIO4ALL installed ( http://www.asio4all.org/ ) and I’ve set the buffer to as low as it’ll go at 64 samples (from Preferences/Play/Audio Device) This results in zero latency. To get the notes played to look correct in the score takes a bit of experimentation with the MIDI input latency compensation (Preferences/Play/Recording) - there are several help guides on how to do real time recording with your keyboard, for example https://www.youtube.com/watch?v=42Gmzl7gQ7k by Dorico’s Anthony Hughes (it was filmed with version 2.2 but still applies). I have my compensation set to 0ms and it all works a treat (with Roland, Novation and Behringer keyboards). As an aside, they all work spot on with Cubase too.

As for Mac, I haven’t tried real time recording yet, but I don’t anticipate any snags.

Good luck!
Rob