MIDI recording not overwriting with Key Editor

In Cubase Elements 6 if I set the MIDI record mode in the Transport bar to Replace, then record in an existing part using auto punch-in and auto punch-out, Cubase deletes the notes in the part within the edit interval and replaces them with what I’ve just played. However, if I have the Key Editor open, Cubase doesn’t delete the existing notes and instead merges them with what I just played. This seems somewhat illogical. Is there a way of setting the Key Editor so that it will behave like the main Cubase window and overwrite the existing notes?

Grateful for advice.

I don’t have Elements, but I expect it works the same as in Cubase.
When you change: File -> Preferences -> Record -> MIDI -> “Replace Recording in Editors” to “All”, notes + controller data will also be replaced in the Key Editor when “MIDI Record Mode” is set to “Replace”.