MIDI Recording

When recording MIDI if i hit the keyboard before it starts Cubase put an additional part before where i want it to start.
I would like to start at the left inspector but if i hit the keys too quick there’s a tail in front of the left curser as well as the recording part i want.
Is it possible to stop Cubase doing this ?


Thanks to this, you don’t miss a MIDI Note, you played just a few milliseconds before the real recording start. Even though I always start record few bars before my music really starts, I find this feature very useful.

If you want to change, you can change the settings in Preferences > Record > MIDI > MIDI Record Catch Range in ms.

Thanks Martin,
That’s saved me hours.

Still getting the added on bit at the start if i hit the key too early.
I’ve tried the catch range setting but it’s made no difference


Did you set it up to 0?

Manual here.

I’ve set it to zero but still the same. It puts an extra bar or two depending when you hit the keyboard infront of the left cursor.
I have pre roll off but pre count on.
Its exactly a bar or two.


There is another preference, Cubase align the MIDI Parts to the bars. If you disable this preference, you will not get the whole bar ahead. You will get just a small part.

Thanks Martin
Is it just me that has this ? i’ve always had this for a few versions of Cubase now.

It’s still there on count in
if you have 2 bar count in the extra bit before the left hand cursor will be 2 bars if 1 bar count in it will be 1 bar