MIDI Recordings are sloppy

Hello!
For some reason I have this problem, that when I play with keyboard, everything feels in time, but when I hear the MIDI recording it feels sligtly off here and there. I tested creating a Bus channel and had audio recording at the same time, and the MIDI and Audio was not the same. Any ideas? Thanks!

When, for example, recording only 1/4 notes, the very first one is one the right beat, wheareas all the other MIDI notes are early some milliseconds.
Well, fortunately, I can shift the others with a click of a mouse and it works but it is not normal. I have had this problem for two years but I wasnt daring to suspect that anything is wrong with the Cubase…

Hi,

Are you on Mac or Windows?

Could you attach a screenshot of the MIDI/Audio comparison? Open MIDI In the In-Place Editor, to be able to see both tracks side by side, please.


I am using Windows.

Hi,

Could you try to enable the WinRT driver type in the Studio > Studio Setup > MIDI Port Setup, please?

It was already enabled

Hi,

I see. And if you disable it?

Doesn’t make any difference

My findings are even worse than that.

In the below screenshot, the red MIDI and red Audio track were recorded at the same time. The subsequent audio tracks were recorded from playing back the red MIDI track. The three examples are all from the same take.
image

image

Record format: 48kHz / 32bit float
Cubase 12.0.70 Pro, Windows 10, WinRT MIDI selected (deselecting WinRT does not make a difference).

oh Wow.
How is this possilbe?
I have Cubase 13 now and there is no to fix it? Is everybody having this porblem?

I think it’s one of those things that gets brought up every now and again but nobody seems to care enough to do anything about it.

And there is no way to fix it?
How is this possible? Wow

Hi,

Could you please explain more your setup? What are the green, blue and black tracks? Are these different Audio tracks recording from the very same source? Did you record from track to track, or did you send the data out and in?

Do I understand you right, you tried this 3 times and these 3 tries are these 3 pictures?

I first recorded the two red tracks. One MIDI Track and one Audio Track. Both at the same time from the same digital piano.
I then routed the red MIDI track back to the same digital piano, and recorded the green track from the piano. I repeated this process for the blue and teal track.
Red audio/MIDI tracks = live performance
Green, blue and teal tracks = red MIDI track performance

I did these test with both WinRT MIDI turned on and off. The screenshots are from when WinRT MIDI was turned on.

I did the above once. The screenshots are from the same test, about 4 bars in 120 bpm. I zoomed in in a few different places and took screenshots to show that the timing is varying.

1 Like

Maybe there is and I just missed the memo. Perhaps these issues are confined to Windows machines only. I don’t know.

Have you tried enabling ASIO Latency Compensation & Add Latency to MIDI-Thru Processing in the preferences?

It fixed the timing discrepancies between MIDI and audio on my side. Also using Cubase 13.0.40 & Windows. See the video below for an example, I’ve time stamped it to the relevant section:

1 Like

I did another test just for fun.
This time I drew in some MIDI notes (black track) and routed the output to a 5-pin MIDI port. I connected a 12" (30cm) MIDI cable from the Output to the Input of the same interface and recorded the result 3 times using different settings in Studio Setup. There isn’t enough data to make any real conclusions but it appeared WinRT with “Use System Timestamp” turned off, had the least deviations.

Below I have cherry picked some screenshots to show its variances. The ruler on top is set to seconds.

Thank You!
It did it much better! I hope i won’t be having problems now.
Before:

After:

1 Like