MIDI remote control function : Cubase 12 : Novation Lanuchkey 61 : pads not detected


Does anyone know why Cubase might not be detecting the pads when pressed in the midi remote mapping.

I had this issue when I was trying to discover the pads on my M-Audio Hammer 88 Pro. For some reason, it had to do with the preset that was selected on the Hammer 88. When I changed the internal preset to a blank user preset (as opposed to pre-configured presets that were created for other VSTis from the factory), then the pads were detecting in the midi remote mapping.

One other thing to check is the midi port that is being used for the controller. Like with mine, there are multiple available ports - one will say something like “Hammer 88 Pro Mackie/HUI” and another just says “Hammer 88 Pro MIDI USB” and then another says “Hammer 88 Pro MIDI DIN.” Depending on the mode that the keyboard is in, it may want to use different ports for different ways that it functions (like DAW transport functions vs other functions in DAW mode vs Preset Mode). This is likely not your issue but it’s something to check, in case the pads aren’t detecting based on the mode that the keyboard is in vs the port being used when creating a new midi controller surface in that edit section.

One recommendation I could give is to create two separate mappings for the pads with Novation Components (I don’t own a Novation piece but it looks like you access it by going to components.novationmusic.com).
Then for the first mapping, leave the pads as regular notes for your main mapping, then don’t create anything for the pads in the Cubase Midi Remote mapping window since these will just trigger the same notes as the keyboard.
Then for the second mapping in Novation Components, change the pads from notes to transmit CCs instead. Then in Cubase midi remote mapping, create a new “page” for this configuration and then your pads will for sure detect since they are now CCs and not notes.

The issue I described in the first paragraph with my pads not detecting was when they were set as regular notes (C1, D1, etc). When I changed them to transmit CC messages instead of notes, the pads always detected, even when I didn’t create a new blank user preset on the device as mentioned.


Thanks a lot for taking the time to respond.

I figured it out :slight_smile: and am grateful.

Do you know if there is a command that can apply a level send only whilst a pad is held, i.e. when I take my finger off it is disabled or goes back to a base level.

What I’m trying to do is add piano spikes in dub reggae. I.e. a sudden heavy reverb then back to subtle.

My current workaround is to use 2 pads, one increases the signal and the other takes it back to the subtle level.