Midi Remote fails to see multiple banks of knobs and faders

I have an Arturia Key lab61 Mk11 which has 9 endless rotary controllers, 9 faders, and 9 buttons. Next to that section of the controller are three buttons that allow you to activate bank 1, 2 or 3 of the physical knobs and faders. I tried to add three banks of knobs and faders in the surface designer by clicking on a knob space in the designer and then touching the physical control knobs and all worked fine - I created 9 assigned knobs. I then left a space in the designer and tried to create a second set by switching to bank 2 on the physical controller and repairing the process. All worked fine!! However when I tried to create bank 3 it just tries to overwrite bank 2. Why won’t it work?

I’d imagine that Bank 2 and 3 are set to the same MIDI CC on your hardware -You can check by going into the user edit mode, or checking in the control centre software what your current preset banks are mapped to.

Thanks for the advice - will take a look.