Midi Remote Mapping "no mapping" on fader doesn't let CC signal through

I have a Kork nanoKontrol2 which has a built in midi remote mapping script provided by cubase. Previous I had set the first two faders on the nanoKontrol2 to CC1 and CC11 for mod and expression using korg’s Kontrol editor.

With the new Midi Remote Manager I am not getting CC1/11 for those two faders either in the CC control lanes or in the midi monitor on a track.

If I disable the controller script, then I receive CC1/11 from those faders as before Cubase 12 and the new midi remote mapping.

If I create a new mapping page and unmap those two faders by explicitly selecting “No Mapping” from the function browser, I still don’t get the CC1/11 coming through (checked with midi monitor).

I can assign those faders to other things so the hardware and setup is working, I just can’t get midi remote manager to ignore them enough to let the hardware configured CC to come through.

Is there any way to get let the device’s built in CC signals to come through when using the Midi Remote Manager?


Could you please attach a screenshot from the KORG KONTROL Editor when selecting the 1st and 2nd sliders, to see your custom assignment?

Of course, I edited the top level post with a screenshot of the mapping assistant with the first fader selected. Thanks.

Oh wait, that’s not what you asked. Yes, let me get a screenshot of Korg Kontrol

OK, uploaded korg editor screenshot.

While messing around I tried disabling the built in korg nanoKontrol2 script from cubase and making my own script from scratch using the graphical editor, completely omitting the faders entirely. This appears to work and is a reasonable workaround. I would love to be able to just add a mapping page to the stock script though as the other stock mapping pages are also very useful and switching between them is great.


All the pages share the very same incoming MIDI data. You cannot add other Page, which would receive other MIDI data but the other Pages.

The default settings for the nanoKontrol’s faders are MIDI CC0-7, right?

With the new MIDI Remote, just creating a control will exclude it from transmitting into the project/timeline data. It doesn’t matter if there’s a mapping assigned to that control element or not.

You can disable a script which would give you raw transmission again, but it’s an ugly solution if you’re continually wanting to move between the two modes.

Yes, those are the defaults. I remapped the first two sliders so I can use it for mod/expression when composing with sample libraries.

You can disable a script which would give you raw transmission again

Yeah, I think that’s where I am now. I disabled the stock script and created my own without adding the faders. That appears to work for now. I appreciate the help.