Midi Remote>Meter All

I have set a control in Midi Remote to the function “Meter All” from the selected track, to send a cc value with the VU value of the track.

The VU output from Cubase Midi Remote is sending the values using a curve like this:

When the fader is at the top or near the top, the cc sent by Cubase is similar to the meter of the track.
But more I move the fader down, more difference I see between the cc value and the meter.
Cubase doesn’t output anything other than “0” when the level is below 20% (visually) on the scale.

Is this a known issue or it is by design?

I am using Cubase 12.0.70 / MacOS Ventura 13.6.7

This is not an issue and has also nothing to do with ‘design’,
but with physics from the field of acoustics.

Example:
An increase of 10 dB corresponds to a doubling of the volume.
:wink:


Meter All CC vs Audio Level

The relationship between the Audio Level of the track (influenced by the Channel Fader) and the “Meter All” output value is shown in the diagram above. The horizontal axis shows the Audio Level in dB, the vertical axis shows the CC value (=Meter position) from 0 (all the way down) to 127 (all the way up). Due to different scaling, the visual positions of Channel Fader and Meter differ from each other.

Different Scaling
Different scaling

This is what puzzles me:

Roughly, that would be about -38dB on the meter. So are you saying that a signal that reads -40dB on the meter outputs 0.0 (floating point) from Meter All in MIDI Remote?

I think this is meant visually. Visually the Meter output below -30 dB is as good as zero (lower end of the scale). But the CC value at -40 dB is still at about 16.

:scream:


While every 6 dB SPL represents a doubling of amplitude, a non-exact rule-of-thumb is that every 10 dB increase is a doubling of perceived loudness - Sengspiel
Fader and Meter is about (analog voltage/digital fs) amplitude, so doubling is 6 dB.

I’m not sure why you’re bringing CC values into this. I’m talking about the vertical axis in OP graph. I am assuming these are the normalized, absolute floating point values that MIDI Remote (and VST parameters) use.

So be careful when you ask a drummer to play 10 dB louder.
But I don’t think he understands that.
Tell a drummer to play more dynamically and he’ll say
“What? Dynamic? Sorry, this was already my loudest!"
:wink:

It doesn’t matter, both scales are linear (0…1 or 0…127). The CC values are used when “Meter All” is controlled via MIDI.

Volume = loudness?
:scream:

Probably my post was not clear enough. I am not talking about loudness or physics or volume.

I am talking about the cc values that Midi Remote sends to transmit the VU of a Cubase track. It seems to me that Cubase is sending wrong values.

Why do I think that Cubase is sending wrong values? Because when the VU of the track in Cubase is visually at the half of the VU meter, Cubase is sending a cc value around 10. It makes sense to me that Cubase should send a value around 64 in that case.

I have done a short video that can show better this behaviour. The video shows a C12 project with one audio track with one effect that plays a sine of 440 hz at 0.00 dB. The video also shows two buttons of my Stream Deck, where both buttons receives the cc value of the position of the fader and the cc value of “Meter All”. Values are shown like this:

SD VU

This is the video:

:roll_eyes: Didn’t say that, but

I understand what you mean. You’re bothered by the discrepancy between level display in the mixer channel and output value of “MIDI All”. The level display is centered at approx. -21 dB (visually 50% of the scale), while at the same time the output value of “MIDI All” is at 8 (out of 127, i.e. 6%). This means that it’s not possible to get a reasonable level display on an external display device (like Stream Deck) using this value. Since you can’t adjust it, in my opinion, this is a case for a feature request to Steinberg.

I’d like to try this myself but I’m struggling a bit to bind these to a custom value variable.

In any case, have you tried with both mVUMeter and mVUMeterMax? I’m assuming one of them is “Meter All” in the mapping assistant. (Otherwise I don’t know where to find it.)
image

I have tried all: MeterMax sends the maximum level, Peak sends the peak and Clip sends the clip.

MeterAll is the parameter to send all the levels of the meter.

So, I assume that this behaviour is intended and not a bug.
Thanks for the replies and all the information.