Midi remotes not working. Could it be due to conflicting remotes?

I’m running Cubase 12.0.70 Pro on Windows 10 and I have 4 different controllers. (Icon Qcon gen 1, Presonus Faderport, NI Maschine 3 and a Akai MPD218).

I use the Qcon and Faderport mainly for the faders but now I thought I would put the rotary knobs on The Akai MPD218 and the Maschine to work. I have watched several videos on Youtube on how to set up a remote and I’m 99% sure I’m doing the right steps but I just can’t get it to work.

For the Akai I set up a new surface and tried to create my own script. The rotary knobs and buttons show up perfectly in the lower midi remote window and I’m able to place the to my liking (mimiking how they are placed on the hardware). Then I go to the “Mapping assistant” and assign what I want to the rotary knobs, e.g. send level for selcted channel. The rotary knob that I touch on the hardware gets selected and I double click the desired command in the functions browser. I hit “apply mapping” and from there it should be ready to go but nothing happens on the selected channel when I turn the knobs or press buttons.
I tried to create a new mapping page instead of using “default” but it didn’t work either.

In the midi remote manager my Faderport shows up and is working. The Qcon doesn’t appear in the list but is listed as Mackie Control. Both the Faderport och Qcon seem to work happily together so that if I move a fader on the Qcon it moves on the Faderport as well (only tricky when I’m touching two faders on the Qcon).

My theory is that the Faderport is somehow in conflict with the Akai and the Maschine. Could this be the case?

Any other ideas?