Midi Routing lost on instrument disable/enable

I only just bought cubase, and just made this template, so this has nothing to do with legacy versions nor old templates. I can see that they claim this bug has been fixed some years before, but obviously it hasn’t as I’m a new customer on the latest version of Cubase 12.

Here is a video of it not working. In a big template
streamable com/568vbi

and Heres a video of it not working in a completely empty project
streamable com/g25lvw

Steps to reproduce if you can’t be bothered to watch the video:

  1. Make an instrument
  2. Route midi to it
  3. Disable instrument
  4. Enable instrument

Midi connection will now be “Missing”.
Whether you include the midi track when disabling/enabling too makes no difference, same result.

Template here:
drive google com/file/d/1OHm9GtDiGz_6faBJYI8_6f_TNleuH5WL/view?usp=sharing

I bought Cubase almost purely for this disable/enable track feature, only to find it just breaks your project every time you do it. So I’m absolutely seething to find that this issue is actually 8 YEARS OLD, and continually swept under the rug.

Others seem to have issues only when doing it in a certain order, but as you can see from the video this happens for me every time, so I would consider that a different issue so do NOT close this issue and refer to an already dead and ignored post.

Workarounds would be appreciated, but a fix for this is absolutely vital as otherwise, this feature is useless.

All of this on a fresh instance of Cubase, on a computer that has never any other version of Cubase on it as I am a new user.

Hi and welcome to the forum,

This is known and already reported issue. Thank you.

Do you have a particular reason to work like this?
I mean, setting up this instrument stack in Kontakt with multiple MIDI channels.

Why not create separate instrument tracks?

Hi,

This is common way to save the CPU load. Using 1 Instrument (Kontakt) instance and multiple MIDI tracks routed to the Instrument (Kontakt) can save the CPU load significantly.

1 Like

With the latest generations of Cubase and even more so with 12
the problem no longer arises
It handles an incredible number of separate instrument tracks very well
and if your versions of plugins such as Kontakt or Opus or others are in VST3, it’s even better

1 Like

This is what I’ve had to resort to. Which is less efficient resource wise and less convenient setup and speed wise. Definitely a workaround and not a fix, one I’d rather not do.