Midi send doesn't "send" when in drum & key editors?

Hi folks,

Here’s the dealy:

I’ve got a midi track which i’m recording all my drums on. (let’s call this midi track “Drumz”)

The midi out of Drumz is going to my Roland hardware drum module to trigger the hi-hat.

All my other drums are coming from Kontakt.

To get my midi from Drumz to Kontakt I’m using a midi send. That seems to be the only other way (if your midi out is already being used) to send midi to another destination.

So far, so good.

The weirdness / annoyance comes when i try to edit in the key or drum editor.
If i click on a hi-hat midi note on the grid, the hi-hat will sound.

But any midi note that’s being routed to the send won’t make it through to the destination (in this case, Kontakt).

Even weirder, although this doesn’t work, if i click on the vertical piano keyboard in the key editor, it will send a message through the send.

So it seems like only manual actions (like clicking, moving) taking place on the grid (key or drum) aren’t sending midi data through the send.

Anyone come across this before or know of a solution? Is there some other way (other than a midi send) to route midi from a midi track to 2 or more destinations. Or is there a setting somewhere to change?

By the way, I’m aware i could get it working with a LoopMidi kind of solution but i really don’t want to go there as that always makes things buggy and unstable.

Thanks! …J

Ok, i found the solution in the midi section of the preferences, but will leave up this post in case anyone else comes up against the same issue:

1090 from the manual (Cubase 9):

"Audition through MIDI Inserts/Sends
If this option is activated, the layering of MIDI instruments (by MIDI sends) is
also active within the MIDI editors. This way, the acoustic feedback of the editors
sends the MIDI data not only to the output selected for the track, but additionally
through any MIDI inserts and MIDI sends assigned to it. However, this also means
that MIDI events will be sent through any MIDI plug-ins assigned to this track."

Jazzius, thanks! Just needed this :slight_smile: