Midi signal from keyboard shows on Halion but no sound

Im using 9.5 on a Mac mini
I can see the midi signal is coming in from my keyboard in Halion
and I can play the sound on the Halion keyboard and I can hear it!

Ive tried changing the midi channel, out put channel record enable, monitoring and …no sound!



Do you use the 1st slot and MIDI Channel 1, please? Has the sound been loaded?

What about the Preferences > MIDI > MIDI Filter? By default only the SysEx is filtered out.

Hi Martin, thanks for the quick answer!
Yes to all of your Questions

it was working ok and then I must have changed a setting

Any help would be great!!!
Thanks and Regards

Yes I forgot to add! when I press the keyboard you can see in 3 places where the midi signal is coming in.
On the keyboard at the bottom of the Halion you can play it and hear the sound



The MIDI Input of your track is iCon Neuron. Is this your MIDI Device, please?

Can you see the number 1 blinking in the HALion Sonic SE?

Yes it is

icon Neuron is the keyboard
I will check if the 1 is blinking tomorrow as I have closed down my system and also have an early start in the morning
I will update tomorrow
Thanks Again!

Hi Martin
When I play the keyboard the 1 is blinking
Screen Shot 2022-07-05 at 15.56.16
When I play the Halion keyboard it also blinks and also I hear the sound



That means the MIDI data had been received by HALion Sonic SE.

Can you reproduce it? Does it happen if your ad a new HALion Sonic SE instance?

As you can see I have loaded a second halion and its exactly the same
What did you mean " Can you shared reproduce it?"


Screen Shot 2022-07-05 at 16.29.09

Hi Martin,
a, the midi is being received by Halion
b, I can play and hear Halion when using the Halion screen keyboard
c, so Midi is working and Halion is working and the channel is also working

Icon as input is selected

Halion as out put is selected

Midi channel is correct

That is the status as I understand it, I hope you have a few ideas



Sorry a typo… The question was, of you can reproduce it.

What happens if you insert another instance of HALion Sonic SE, please?

Hi Martin,
yes Ive tried as you can see in this case 3 x
Screen Shot 2022-07-05 at 20.44.45
Ive just tried with my M1 as source keyboard and its the same


This is other MIDI track, not other insurance of the instrument. Just Add Instrument Track, please.

Could you add a MIDI Monitor on a MIDI Insert slot for that track, press a few notes and then screenshot it? That helps to verify which MIDI data is being fed into HALion.

It’s possible that notes are being sent as velocity 0, for example.

Also what version of HALion are you running? Is it possible that you’ve got a version which is much newer than C9 and it’s causing an incompatibility perhaps?

Anything else that may have changed? i.e. Have you tried using logical editors to transform MIDI, or set up any virtual MIDI ports? Updated any Steinberg components?

1 Like

Hi Martin I just tried it and its exactly the same

Hi Ski jump toes :grinning:
Screen Shot 2022-07-06 at 19.28.21
Screen Shot 2022-07-06 at 19.31.34
Regarding your other questions *

Have you tried using logical editors to transform MIDI, or set up any virtual MIDI ports? Updated any Steinberg components?
No new components and I have never done logical editors


You’re showing “note off” messages there, with no “note on”, and no position/timestamp either.

You should be seeing something more like this:

I’ve never experienced this so can’t really help, but I’m sure @Martin.Jirsak would’ve seen something like this before.

You getting the same phenomena when using a second MIDI keyboard too?

I’m guessing it could be one of the tick boxes in the ‘MIDI Port setup’ section within Studio Setup, it may be worth just taking a screenshot of that page too, so you can get this fixed?

Yes as soon as I saw no note on’s that must be it
And yesterday I tried my m1 and it was the same
Screen Shot 2022-07-06 at 19.47.37
So the out put is inactive, and it said the same yesterday with the m1 so how to switch it on?

so I’ve got it active now and…theres still no sound!

Any new ideas?

Regards and thanks to you both