MIDI Step Input Cursor Linked to Modifier+Click Playback Cursor Placement

Apologies, have to do this one quick.

Based on “surrounding behaviors”, this seems to be an unintentional linking.

Steps to repro:
x.) Disable ‘Locate When Clicked In Empty Space’ preference
1.) Create MIDI Part
2.) Open MIDI Part Editor
3.) Activate ‘MIDI Step Input’ mode.
4.) Left click anywhere in the MIDI Editor timeline
5.) Result is, you will see blue Step Input cursor move to that location.
6.) Modifier(Alt+Shift for me)Left Click a different location to move PLAYBACK cursor.
7.) Result, you will see both the Step Input and Playback Cursor move to that position.

Compare to:
a.) Left clicking in the ruler to place Playback Cursor. Only Playback cursor will move
b.)Use navigation key commands to move Playback Cursor Only Playback cursor will move

Happy music making,
Paco

Hi,

Where is the issue, please? To me it sounds like a feature. Alt+Shift+click moves both cursors. A click (without modifier) moves just the payback cursor.

I perhaps forgot an optional variable.

disable ‘Locate Cursor if Clicked in Empty Space’.

edit:

@Martin.Jirsak I’ve revised the original repro.

It makes more sense for these functions to be separate, as one may want playback position to be different than Input Cursor position, because, you usually want to listen to a note change in the context of the notes immediately preceding it.

I don’t think it’s an intentional feature, although, the protocol might need to be adjusted/inverted for someone who does have the ‘Locate When Clicked in Empty Space’ preference enabled.

Thanks and happy music making,
Paco