Midi step input not working

I must miss some very obvious thing here. I bought a midi keyboard (at last), connected it via usb and try to input notes. I’m in note input mode, and I hear the correct noteperformer instrument when pressing keys, but no notes are input… In another music notation program it works. I restarted Dorico after connecting the keyboard and I’m really using note input mode (caret activated).

Just a wild guess: have you accidentally pressed “,” so you are inputting rests instead of notes, and they won’t be displayed until you enter a note somewhere and Dorico knows how to rhythm correctly?

Check the “rest” icon in the left hand panel isn’t displayed.

Thank you. The Rest icon is not selected however. Also, the caret is not advancing…

The strange thing is, that I hear the NotePerformer feedback of the first instrument that has selected notes in Dorico, which doesn’t have to be the instrument that has the caret activated.

Can you make a screen recording of the whole Dorico window showing what you’re doing, and attach that here or a link on Dropbox/Google Drive?

Thank you for looking into this. I uploaded a video demonstrating, in this order:

  • note input by computer keyboard works
  • note input by midi keyboard not working (Yamaha p515 digital piano); only sound works
  • you hear the sound of instrument with selected notes, instead of instrument with caret
  • (sanity check) in another software, midi step input works

https://photos.app.goo.gl/GqsxwaRgQqgXRdc16

As I said, I probably something obvious.

Very strange. Can you do Help > Create Diagnostic Report and attach the resulting zip file from your desktop to a reply here?

Thank you, this is my diagnostics file.
Dorico Diagnostics.zip (384 KB)

As far as I can see from the diagnostics, everything should be working. The audio engine sees the digital piano device, and you’ve not disabled any MIDI input devices in Dorico. Can you try capturing the output of your piano, in case there’s something peculiar that Dorico isn’t expecting? This procedure should allow you to do it. What make and model is your digital piano?

I will do that in the next days. My piano is a Yamaha P515.

Here is a dump of the Midi Monitor application, I hope that you can find something. Thank you.
Untitled.mmon.zip (27.4 KB)
Screenshot 2020-04-11 at 10.32.24.png

I think the issue might be that the P515 is sending a lot of real-time Active Sensing messages. When Dorico is running, does the little round MIDI indicator in the bottom right-hand corner of the window show as continually lit up green? In normal operation it should only light up when you actually play notes on your keyboard, so if it’s lit up green continuously that would be a clue. (My recollection is that we have implemented filtering for Active Sensing messages, but it’s a holiday weekend and I can’t easily check with Paul right now.)

The problem is fixed. I browsed through all options in Dorico further and further and in the end, the relevant option was in the preferences under Play: ‘Enable MIDI input’.

I apparently unchecked that option once…

The ‘Play’ section was not where I looked for input options.

So it was really something very simple.

Thank you for all the support!

Wonderful, I’m glad you’re up and running.