MIDI Sync Troubles With Q7

Hey all,

So I’m new to the ‘Q’ and have set up about 3 templates for recording so far.

One of them is to transfer my MIDI sequences from my physical sequencer [Roland MC-50 MKii] and record them into Cubase.

I set up individual tracks, and although they’re coming in from one of 2 outputs from the MC-50, I do have the tracks with their own MIDI channel numbers - about 6 tracks.

So they play out of Output #2 of the MC-50, into a Roland UM-550 MIDI interface which is seen by Cubase, as set up a few days ago.

But - when I play the tracks, all of them play across all tracks in Cubase, so they show up, but do not separate into their own channels in the DAW. ie: if I play track 1, all the channels indicate the same MIDI note on/offs; same if I play track 8 - all mirror each other.

Additionally, I cannot get either one [‘Q’ & MC-50] to slave to another, even after much reading in the operation manual and countless attempts of all kinds of different possible settings trying each one as the master and the other as the slave.

I’m by no means a newb, as this is my 3rd DAW now, and have been successful doing this with both my other 2 DAWs, [although one DAW can only be the master] - hence my surprise & subsequent frustration at having no luck at this after hours & hours of trying today.

I have been able to get Sonar to be both slave & master. So I’m quite comfortable with the process.

I’ve also owned this MC-50 sequencer for 17 years, and it has yet to fail, freeze up or die on me.

I’ve been in & out of the Devices Menu & it’s options and again my device is being seen by ‘Q’, but something is obviously a skew.

I jumped from Sonar to ‘Q’ just last month, primarily for the extra MIDI editing options, so I’d really like to get past this first and only stumbling block so far.

Seems like I’m missing something simple & obvious, but I’ve only had ‘Q’ open a half dozen times so far.

Any help would be great.

Thanks in advance,

James

Sounds to me like you’ve haven’t properly specified the midi channel as source on the recording tracks and they are recording “All midi channels”, which is what is probably selected as default.
It might be good to check a couple of the routings individually initially.
I am assuming you’re recording the midi data here correct?
As for audio, you need similarly to check the input routing to separate channels on the HW.

Ok, so after another go 'round, I do have some results after all - at least half way there, anyway.

I did get the sequencer to slave to Cubase after some more horsing around.

Most of it had to do with my external hardware.

In addition to the sequencer, I have the UM-550 MIDI interface to set and a Yamaha MEX 8 MIDI Expander to switch MIDI cables over, under, around & through so to speak.

Then I was able to organize things better inside Cubase, although I am still stuck with recording only one track at a time, which is fine - I don’t mind - as more care & attention can be given to each track as I transfer it, but it just seems a bit of a mystery, since I have been able to do all tracks at once in the past.

I’m also still left wondering about not being able to slave Cubase to the sequencer, as it says it can be done in the manual. :confused:

Based on my findings above, I’ll bet it has to do with my set up again, most likely, although I tried & tried & tried different things all morning, with no luck.

Not that big of a deal though, as long as I got Cubase to be the Master, which it would have to be in the long run anyway, when the time comes for adding vocals, guitars & bass, so it might as well be from the start.

I made a whole pile of notes as well, both of my external hardware set up & internal settings in Cubase & saved the project of course. :wink:

I have not been able to find how to do that - do just that, in fact - ‘specify the midi channel as source on the recording tracks’. I’ve looked & looked through every available menu and manual step I can find, but clearly I’m missing something here.

I do remember in Presonus Studio One that I did have to set up the sequencer showing whatever MIDI channels I wanted to use & could then pick & choose for each track, but I don’t know where or how to do that in Cubase. Any help there would be much appreciated!

I’m open to any advice or ideas here, if you’d care to elaborate.

Not sure how ‘recording the midi data here correct’ differs from what I’m trying - so feel free to specify if you wish.

In the Operation Manual it is explained quite well specifically page 124-125 (Eng. version).
By Midi data I simply meant as opposed to an audio output.

I’m not too familiar with the Roland MC-50 MKii but given to understand it is purely a midi sequencer and has no voicings of it’s own. So what (instrument) are you controlling a vst?
Halion e.g. will record multiple midi channels and play each one on it’s own separate track simultaneously.

Oh yeah yeah - I’ve been recording MIDI for almost 20 years now.

In fact, in 1997, I was on the phone with one of the Roland tech guys, giving him some things to add to his notes that I found out by using one of their MIDI products, after he wasn’t sure how to answer my initial inquiry to him about that product.

So, much like today & yesterday, I spent a few days doing trial & error and thought it would satisfy his curiosity to know the answers and also have them to help others who might have the same questions some day.

Yes the MC-50 is strictly a sequencer - no sounds or audio at all.

I trigger my MIDI sound modules & VSTs using a Yamaha Digital Piano P-200 - 88 keyboard controller and a Novation ReMote SL37 smaller desktop keyboard.

I trigger & record my drums with a mesh head V-Drum set up using a Roland TD-6 brain.

Thanks for the tip - I was at page 124 twice yesterday, but I’ll have another look.

I understand about the Yamaha Piano and the VDrums and I suppose these are working in Cubase without problems.
Is the sequencer also routed to these devices, or Midi modules or VSTis or all of the above as output?
To clarify; are you routing the sequencer. for example, through Cubase to your VDrums?
Another thought here, do you need to control the sync - i.e. clocking? You may need to reveiw the Synchronization chapter on page 650 also Pg 16-17. (If in doubt, leave the external clock unchecked).

Hey BriHar, thanks for the reply.

I’ve started a new post in better detail just a minute or two ago, so for the sake of repetition, it should answer some of your questions to me on this.

As far as the syncing goes, I got it working where Cubase is the Master and the sequencer is the slave, so that’s working fine, [even though it should work both ways]. But I’m ok with it this way as it is now.

The post is here:

https://www.steinberg.net/forum/viewtopic.php?f=181&t=45320

Try recording all MIDI data from the MC on a MIDI Track and then use the “Dissolve” functionality in Cubase.

Yes, it turns out that this is exactly the answer.

Thanks!