MIDI Tempo Mapping: advice needed [and got]

Hi. I have a track of MIDI, not recorded to a metronome and in fact varying in tempo quite significantly (intentionally). I now want to build a tempo map and, in doing so, align the right notes with the start of the bars but keep the speed I played at. I’ve had a look at the two prescribed methods for doing this but it’s not working out and I’m wondering if anyone has any advice on what must be a fairly common procedure.

Project Ruler: Seconds, Time Linear
Original “Tempo”: 145 bpm

Tap Tempo

  • I built a Tap Tempo track as per manual, consisting of just the bass notes of the recorded MIDI.
  • Select All
  • Merge Tempo From Tapping
  • Switch on Tempo Track

It plays back slow. If I turn the Tempo Track off then I get back the speed I played at. NSG.

Warp

  • First, I have to switch Tempo Track on, at which point the bpm goes to 120 and won’t let me change it!
    Using the Tempo Tap track previously created for simplicity:
  • With the Warp Tool (editor ruler displaying Bars & Beats), anchor the first beat to bar 5 (where it is anyway).

Seems simple enough but the Piano track soon gets out of synch, playing much slower than it should. You can see this in the Project Window - the Piano and Tap Tempo tracks are visibly way out of line. NSG either.

Been on it for a while and can’t suss it. What am I doing wrong?

Cheers,
Crotchety

You have to go through the whole tune putting the bars in the right place with the Timewarp Tool. Once done you save the groove as a Groove Template which is selectable in the Quantize field to apply to other tracks.

Timewarp video here:

http://www.steinbergusers.com/vids/XML_players/cubase/cubase_videos_content.html

You should also make sure that the tracks themselves are set to Linear Timebase (including your “tap” track).

Which method you use really depends on the actual content. The advantage of using the “tap tempo” method, is that you will be filling in all the downbeats that might not have been present in the actual performance… and you can always edit your “tapping” afterwards, if you went a bit astray somewhere (the better the tap track “feels” against the music, the better the end result will be :wink: ).
The TimeWarp tool is great also, but might be better suited to music that is fairly “regular” in character.

Rendering to audio and using the Sample Editor to enter hitpoints and then converting the hitpoints to groove template via the Audio menu is another method.

Merge tempo. Probably best with a sharp drum instrument attack.

All tracks need to be set to “musical”. Line your midi starting track with the first barline that makes sense (which may be easier with Audio tracks).

Once the Tempo has been merged then the guide track should be discarded so as not to confuse (people like me when I first did it) as the tempo track will/should have been established and the midi tracks should then follow that timing.

(sorry, no. Linear while actually doing the tapping and then using the function). Can switch back to “musical” afterwards.

Ah! Forgot that, sorry.

Thanks for the Linear Timebase tip, Vic, which I had missed because the button isn’t visible by default. It is now!

For a minute, I thought it had worked. All the Tap Tempo beats were out, the events on both tracks had been shifted back considerably (to be expected, I suppose) but weren’t aligned with the Tempo Track changes. But eventually I twigged, dragged the MIDI events to line up (all spot on the grid) and it looked fine at a glance in the first part.

(But why did the mis-alignment happen in the first place?)

However, the events in subsequent parts aren’t lined up with the grid. Nads! I wonder if that’s because these tracks have several parts on them?

That’s one for tomorrow, I’ll just leave this progress report for now.

Thanks again,
Crotchety

A quick guess (without actually seeing the Project :wink: )… in the “Merge Tempo from Tapping” dialog, either you ticked “Begin at Bar Start” when you shouldn’t have, or maybe you didn’t when you should have :wink:.
You may find it useful to use the TimeWarp tool to line up just the first beat, then continue with the Tapping method from there.
As regards the “several Parts”, did you do the operation from within the Key Editor, or from the Project window?
Had you done the tapping for the whole length of the music, or just for the first Part? (there may be one “bogus” tempo event at the end of the first Part).
Normally, none of the above should pose a problem :slight_smile:.

Morning (again). Okay, I think I’ve got it now, it only works on single parts. Thanks to all contributors. Had a little play and come up with the notes below (I wonder if I’ve found an unintended feature):

Merge Tempo from Tapping

To remind everyone, I am building a tempo map on freely played MIDI that I want to line up to bars without changing the playing speed. I am using “Merge Tempo from Tapping” on an edited copy of the played-in MIDI. Both these tracks are set to Linear Timebase (the note/clock button, not visible by default on MIDI Tracks).

From the manual: “If you activate the “Begin at Bar Start” option, the first note will automatically start at the beginning of a bar when calculating the new tempo curve.”

Multiple parts on track (Select All):
No, it doesn’t. The tempo changes are aligned to the bar but the parts remain where they would have been if the option wasn’t selected. Even pulling all the parts into line leaves only the first one correctly aligned.

Single event on track (glued):
“Begin at Bar Start” option leaves everything beautifully lined up. It is only necessary to glue the Tap Tempo track.

Why does it make a difference? Is this an undocumented feature?

Track Mode:
Must be Linear. And stay like that. The first time I’ve fully appreciated the difference between Linear and Musical Timebases. With Linear, the MIDI plays back at the original speed whether I have the Tempo Track switched on or not. With Musical, well let’s just say it doesn’t…

[Edit: if you also put the Marker and Arranger Tracks into Linear mode, they will keep synch with the MIDI events too!]

Right, I’m happy so I’d better get on. I’ll report back if anything crops up.

Cheers and thanks again,
Crotchety :smiley:

I’d used this with audio so gave it a go and it was easy enough. But - and you or someone else may have an answer - how do you unpick an error in the middle of it all? I had “split” a bar in two, by dragging a bar start to what should have been left as beat 3, resulting in two consecutive bars of high tempo. Without deleting all subsequent points, how could I have fixed this? (This was why I went down the Tap Tempo route in the end.)

As far as I remember, because like you I use the tap tempo for much the same reasons plus I’m a belt & braces type I think you have to click on very small points to get things to move where you want them to.
I’ll check later or one of the others will be faster but I think it could be, or was, quite a fiddly little job. OK for the odd point but if you have a lot of small alterations to do it takes time.

Use a Modifier Key while clicking the point. They’re listed in Tool Modifiers in Prefs.

This is illustrated in the accompanying attachment. The area in question is Bars 102-4. Bar 103 should be where 104 is.

I tried using the Tool Modifiers but couldn’t find one that did what I want. I can delete the Tempo Node with Shift, but that just repositions Bar 103 halfway between 102 and 104.

Moving bar 103 to the right, with/out any modifier, just bunches the grid up till it won’t go any further.

I think I need an idiot’s guide…
WARP TEMPO extra bar @ beat 3.JPG

From memory, apologies if it doesn’t work right:

Erase (shift click?) the “node” currently at bar 104 (which I think you said you did already), and then drag the node currently at 103 over to 104. The tempo for the node at bar 102 (164 BPM) will drop down to the right value, and the tempo for the new bar 103 will reflect subsequent spacing.

I’ve had this problem when recording to a tempo track value that is “far” from the average actual song tempo. I’ve learned I can avoid it by setting the tempo track, before recording, to anything reasonably close to the actual tempo of the song. Sure there will still be sliding around to do, but the “bunching up” part becomes less likely (300 BPM sometimes!!).

Hope this helps! :slight_smile:

I’ll try, sometime tonight, do a “mock-up” of the mess you got into :stuck_out_tongue:, but I don’t think there’s a very easy way. The first thing that springs to mind, is to…

  1. Save the Project, then split it at bar #104.
  2. Global “Cut Time” from bar #104 to the end of the Project.
  3. Correct the faulty remaining bars #102 and 103 with the Timewarp tool. (so that they become a new bar #102)
    [EDIT] I’ve just tried it… having cut from bar #104, you’ll have to extend the length of the remaining Part by one bar, so that you can do the necessary with the TimeWarp tool for bar #102… but since there is currently nothing beyond there, no damage is done :wink: [/EDIT]
  4. “Paste Time” at the now-corrected start of bar #103.
    ([EDIT] It worked! :slight_smile: [/EDIT]

All that seems to do is push the problem down the track. Thanks all the same.

Yeah, sorry, it was the pain of chasing it down the track to the end of the song that led to my starting to set the tempo track “in the ballpark” before I started recording. Doesn’t help much though with older stuff, I know :frowning: .

Well, since the master (vic_france!) has answered, I can’t wait to check out his fix! Dollars-to-donuts, it will be exactly on target.

Vic, you’re a total hero and it was nowhere near as tricky as it read. Thanks very much, I appreciate the time you took. (There are some pretty useful-looking functions I’ve been overlooking in there…)

Cheers,
Crotchety

Btw, there’s a slight refinement necessary to #3 above…
As it stands at the moment, we will have cut the event that marks the start of the current bar #104, so there will be no fixed point for marking the end of bar #103
So…
Before doing the “Cut Time” at bar #104, go into the Key Editor and duplicate any note that is supposed to be the start of the (current) bar #104, then move the coped note 1 tick earlier (so that it will still be present in the remaining Part, after you’ve done the cut). After doing “Cut Time”, extend the remaining Part (i.e. bars #1 thru #103) by one bar, so you can now put that extra note back on to the head of bar #104, so that there will be a reference for the TimeWarp tool.
When, eventually you have done step #4 (“Paste Time”), you can delete that extra note.

EDIT… I see you’ve done it already! Easy-peasy! :stuck_out_tongue: