Midi through problem. Unwanted extra midi channels sounding.

Hi. I wonder if anyone can help with this.

I have Cubase 6-5 on a Mac with the R.M.E. Fireface UFX as a soundcard. I’m mainly using midi out to drive external hardware instruments.
I’m not using a U.S.B keyboard but a midi one which I’m plugging into the Fireface UFX midi input. The problem I have, is that when playing notes in, sometimes I cannot stop extra midi channels from sounding even though I only have one individual midi channel set as output in the inspector of the given selected midi track in Cubase.
Which ever track I select up and down the list, I always hear this extra midi track sounding. Sometimes it seems as if the cubase midi track is somehow being sent to another Cubase midi track and triggering the output of that as well as its own. This never happens on recorded playback of data but only when I’m playing in through the midi input port of the UFX in real time. Once actually recorded, all data plays back exactly as it should.
To make matters even more confusing, it doesn’t happen with every song. From song to song the exact circumstances of this problem can be slightly different too. - For example with one song, I hear the selected track plus the unwanted one (with the unwanted one remaining of the same ch` number whichever desired/wanted midi track I select), - yet I have another song which seems to trigger TWO extra midi channels erroneously and in this case the desired/selected/set proper midi output for this track DOESN’T seem to sound at all.
With other songs the problem doesn’t seem to occur at all. - It all seems quite random when it’s going to manifest itself.

I can find nothing in the R.M.E. Fireface manual about its midi routing and I do not think the UFX is somehow mysteriously circumventing Cubase and passing midi directly from its inputs to its outputs or something , since it only happens when loading certain Cubase songs.
The unwanted extra midi output channel number(s) never correspond with the actual midi channel of the input keyboard (before it gets re-channelised by the output channel number settings in the inspector of the selected midi track in Cubase) either, I’ve checked that, so there’s no connection there.

Finally I don’t have any midi effects activated in midi sends.

If anybody could make any suggestions as to what might be causing this problem and how I might be able to solve it I would be very grateful indeed.

  • Thanks Nick,