MIDI Thru bug in Dorico4 (no audio on MIDI play)

I met this problem few days earlier and didn’t get what’s happening, but today asking google and reading some different issues I realized what’s wrong and this seems to be a bug.

So I open Dorico 4 and create new project from template, let say it’s Solo Piano. I’m waiting until Halion SE sounds are loaded and then I start to playing on MIDI keyboard. The green led in right bottom corner shows that Dorico get MIDI activity, but no sound from the track.

In Note Input mode everything works as it should except sound. I can write notes with MIDI keyboard, but no sound is coming from instrument. When played back recorded notes, all is okay.

I open Play window and open Instrument - Halion SE and click on piano keyboard, it’s playing the sound. Okay, now I open Preferences and scroll to Play category - everything is set as it should be. Enable MIDI Input and Enable MIDI Thru are on. Then I disable MIDI Thru and enable again - now the sound is coming from Instrument.

I would say this happens since latest update.

Hi @ArthurNeeman ,
I think your issue was already raised in this thread. We have already a fix for it which will go public with the next update.

1 Like

Thank you!
But until that disable & reenable MIDI Thru can help. Otherwise this post can be deleted.

Athur/Ulf - same for me. I open a solo piano with Pianoteq 7. No sound etc. But, if I then add say a Noteperformer organ, all works OK.

Win10 Dorico 4.1

Hi @ArthurNeeman , thanks, but we leave this one open here, because that with the reenabling of MIDI Thru is also a good hint, especially for @Thurisaz .

1 Like

Hello, Ulf. I haven’t had this problem until today. No sound from midi keyboard but there is playback sound. I disabled and re-enabled MIDI Thru, but it didn’t change anything. Any other suggestions?

Here is a diagnostic report:
Dorico Diagnostics.zip (1.3 MB)

Thanks for your help.

Hi @Judith_Markovich, another workaround is going to setup mode and adding an arbitrary player and immediately deleting it thereafter. Does that bring back MIDI playback for you?

Wow, speedy response. Wasn’t expecting that. Thank you. In the meantime, I finished for the day and closed Dorico. A message said it had unexpectedly closed. So I reopened it and saved it. It didn’t ask me to make a recovery copy, so I added a player, as you suggested. That not only didn’t work, but I have no audio at all now. That said, there might have been no audio when I opened it, but there is no way of knowing that now. I’ve attached another diagnostic report.
Dorico Diagnostics.zip (1.5 MB)
Signing off for the night but I’ll check back tomorrow. Thx, Ulf!

Hi @Judith_Markovich ,
looking at the audio engine logs, you do have audio but only the metronome will sounds, because in the mixer the DoricoBeep channel is switched to solo, i.e. every other channel is muted.
You probably got into that state by accidentally pressing Alt-S.

Thank you, Ulf. I had checked that before, but must have done it again. Sorry for the time-consumer.
Nevertheless, I still don’t have any midi sound from keyboard.

Hi @Judith_Markovich, and MIDI input is enabled with you?
And try adding in play mode another instrument into the VST-Rack. Some folks say that also heals the MIDI. If not, please send another diagnostics file. Thanks

I already did that. Posted above in post that begins, Wow, speedy. The diagnostic report is there. Do you need a fresh one? Will get back to you tomorrow. Thanks, Ulf.

Hi @Judith_Markovich , but that recipe was adding a player in Setup Mode. The other workaround is adding a VST-instrument into the VST-Rack in PlayMode. Please also try that.
And if it does not work, yes, please send another diagnostics report. Thanks

Ulf! That worked. I added the midi keyboard under midi instruments in the VST Rack. Thank you!!!


1 Like

Unfortunately I have the same issue, but all those suggestions above and in other threads don’t help me. One day everything works fine, the next day no sound when playing the keyboard, but there is sound when I play the score. When creating a new file, I get sound at first, but after a while it just seems connection between Dorico and midi-keyboard is lost.
Studio One is fine, no issues there, so it must be something Dorico related.
I didn’t have this issue until the latest two updates, but since I don’t expect there will be another update soon covering this, I thought maybe it is possible to roll back the updates and go back to a previous version? Or will I be unable to open files created with the newer version?
In the meantime I created a diagnostics report, maybe one of your team could have a look into that?

Dorico Diagnostics.zip (3.3 MB)

Another update is coming pretty soon and it will contain some changes in this area that should resolve the problem fully. Sorry for the inconvenience in the meantime.