MIDI Thru -- weird "all or nothing" behavior - bugs?

Hi all,

I am controlling some outboard gear by hooking up a Griffin StudioConnect via its MIDI in/out ports.

There are 2 issues pertaining to MIDI Thru: first, Cubasis is paying no attention to the actual MIDI channels chosen in the port list. Once MIDI Thru is clicked, it merely echoes whatever channel the incoming hardware signal is, and does not “rechannelize” it to match your selection in the output port. This happens whether I’m using the StudioConnect hardware (5-pin) MIDI ports, or hooking up a USB keyboard via the camera connector – whatever channel comes in gets repeated out. I confirmed this by hooking up a MIDI cable to a MIDI monitor running on my laptop. This is ONLY on live input, i.e. playback of parts on the track DO get rechannelized! Go figure…

Side note: Cubasis’ virtual keyboard DOES respect the MIDI output channel - use the virtual keyboard on a track with MIDI Thru engaged, and it properly transmits on the chosen output channel.

2nd issue: once MIDI Thru is engaged for any track whose MIDI output destination is outside the program (e.g. a hardware MIDI port or a synth running in the background), that track will always sound even if I arm another track. For example, if I arm a track with Micrologue on it, I can also hear the track with MIDI Thru engaged even though it is not armed…I hear them both at the same time. Once MIDI Thru is on for a given track, you hear that track no matter which one you arm! Turn off MIDI Thru and you only hear the currently armed track. And like the above, this happens ONLY on realtime input, NOT on track playback.

So – are these bugs?



Really hate to bump this - and sorry for being too “wordy” earlier - but can anyone confirm the following:

  1. When MIDI Thru is on, MIDI messages sent live from an external keyboard are not rechannelized to match the channel chosen on the output port, but just echo the incoming MIDI channel. The internal Cubasis virtual keyboard DOES however properly send the MIDI channel chosen in the output;


  1. When MIDI Thru is on, the track with MIDI Thru engaged will always sound even if it’s not the currently armed track. This is only on live input from an external keyboard, not when playing back an event on the track with MIDI Thru engaged.

Any attempt to reproduce would be really appreciated :slight_smile:

Thanks all!

I hate to bump this again – and understand that a response such as “we can’t reproduce that” is fine! …but if you can’t hook up a keyboard and have it send messages on a different channel than is coming in, your live input is stuck forever on one channel. If you change the MIDI channel of a background synth or an external device, you have no way to hear it.

Steps to reproduce:

  1. Use any external keyboard (Akai LPK25, Novation SL connected via Alesis I/O dock, etc etc etc). If it has the ability to send on different MIDI channels, make sure it is transmitting on Channel 1.
  2. Instantiate any CoreMIDI synth in the background that can receive on different MIDI channels (for example Waldorf Nave, Magellan, etc) or hook up an external hardware synth connected to a physical MIDI connector. On the synth itself, set it to respond to MIDI channel 2!
  3. Create a MIDI track in Cubasis (disable any Microsonic instrument by choosing “no instrument”)
  4. On the MIDI Connections section of the Inspector, enable the input port of your external keyboard. Leave the channel set to “All”
  5. For the MIDI output port, select the port that is connected to your CoreMIDI synth running in the background, or the physical MIDI output port connected to your external hardware synth. For the output channel, select MIDI channel 2 (important!)
  6. Enable MIDI Thru.

What should happen is that when you play on your MIDI controller, Cubasis should take the MIDI messages arriving at the input port on channel 1, and re-channelize them so that they get converted to the MIDI channel you chose in the output port, i.e. channel 2. But, it doesn’t happen (at least not for me).

The virtual on-screen keyboard in Cubasis does do it correctly, it’s just external keyboards that don’t work. Also, recorded MIDI messages played back on a track are working correctly. It’s something related to the MIDI Thru behavior.

I’m getting desperate here…alternatively, is there any other way to address external sources on different MIDI channels? :neutral_face:

hey Meta,

sorry for the late response.
I could indeed reproduce the issue you’re describing. I used iRig Midi and a Yamaha synth. So there seems to be a bug within Cubasis.

Both the channel assigning and the unarmed but audible track issue are now on our list to be fixed as soon as possible.

kind regards

Thanks VERY MUCH Ludwig for spending the time, I know the summary is complicated :wink:

Strange that no one else noticed it – but great to hear about the planned fixes!

Grüße aus LA,


Any news on when this will be fixed?


Yeah I was a little surprised this wasn’t fixed on the last update - MIDI channels are still quite broken. I guess everyone is just running every instrument (hardware and software) on MIDI channel 1…?

It’s also not on the “Known Issues” chart even though it is definitely known…

You can use MIDI Bridge + FreEWI to work around this problem, but it’s not very convenient…


After talking to the developers I got the information that this behaviour is by design. Cubasis transmits MIDI thru data without modifying it. It doesn’t recognise anything or filter any events. You could even transmit SysEx data over Cubasis to other devices/apps.
To change the behaviour (i.e. being able to filter events or change channels before transmitting them) we would need to do a big refactoring of our MIDI code.
I had added this to our feature request list.

Sorry for the late reply – it took a holiday to get way from Cubase 7 deadlines!

Thanks for the reply. I have to say it’s a little weird, since all versions of Cubase since the Atari 1040ST have performed as expected (lol), but I see what you are saying about translation on input.

I guess we’ll have to wait for a future update.

Cheers -