Midi timeing

Problems with midi accuracy. Everything what I play in Cubase 6 (I am programing only in 64 BIT), somehow, ends up recorded not perfectlly alligned with grid. For a few minuts, on fresh project, MIDI is acctualy, recorded just the way I’ve played it. Exactelly where I played. Aligned with rhytm and grid.
But after a while, it goes ot off sync. I am playing preciselly with beat, but it ends up, in 80% of cases, behind the grid. Very,very little, behind the grid. And, as time passes by, MIDI notes are progresivly further away from grid. And sometimes even before the grid? I am playing in rhytm and it ends up before the rhytm!
It is totally random. I’ve noticed, when project is very heavy on CPU and System Memory, everything happens more radicaly.

I am useing MAC PRO OS X,version 10.6.8, 2x2.4 GHz Quad-Core Intel Xeon,12GB RAM 1066 MHz DDR3 ,2 x PrismSound Orpheus, T.C.Electronic POCO 6000, 3xUAD quad PCI cards, Focusrite Liquid MIX, NEVE summing, MOTU MIDI Micro lite, Roland fantom X7, all kind of soft synths and plug ins, lot of outboard gear, guitars, organs,drums, and so on, so on, so on…

Can anyone help?

Thanx a lot.

Have you got “use system timestamp” switched on? (in devices menu/device setup/midi ports)

Isn’t that a Windows only option?

Thanx Grim But as niles said, it is Windows option. I am a Mac user. But,thanx anyway.

Yeah…sorry didn’t realise that. Still…at least it’s bumping your thread & who knows, maybe a fellow Mac user will offer some advice at some point.

Same problem here on windows xpsp3 (since cubase 4). Not solved (sob). As far as i remember, i have this problem (from time to time) since i sold my edirol um880 midi patch bay and use my bcr 2000 as a midi interface… Maybe it’s related.

Thanx Jules…maybe changeing MIDI patch will give better results…but somehow, I bellive that every manufacturer is responsible for what they are manufactureing…maybe I live in ideal world…but that’s the way it should be…at the end, MIDI patch is not some kind of heavy sience…
so, regardeing my problem, no one, so far,has a solution?..
keep hopeing…

Here’s my understanding of the situation, which is what I suspect is happening here:

When you start a new project, you generally have a low ASIO buffer (low latency) so your playing is more or less aligned with Cubase and your recorded parts are in time. However, as your projects get bigger you may need to increase your ASIO buffer, and perhaps add inserts and effects into the audio path, which results in greater latency (the time between playing a note and actually hearing it). As a result, you may subconsciously start to play ahead of time to compensate for the delay. The same thing happens with church organists: there can be a >500ms delay between pressing a note and actually hearing it, so they have to play ahead of time. I’ve realised this is exactly what I do in the studio. This plagued me for years and I was convinced the problem was Cubase and MIDI timing errors. Then the penny dropped!

To combat the problem, I have set up a key command to push my notes forward by the necessary amount, depending on my ASIO buffer size. In fact, I have a macro assigned to Q. It shifts notes forward to compensate for me playing ahead of time and quantises.

Hope that helps!

Thank you Steve for your effort.
My situation is a bit different. My midi problem starts after (sometimes) few minutes or (sometimes) half an hour. MIDI (what is recorded and visible in editor) is little bit late but when I play everthing seems, I mean, sounds, precise. During programming stage I dont have lot of plugins inserted everywhere so I keep latency very low. And problems with midi begin at this stage. During mix stage a have huge number of plug ins everywere but I dont do programming at this stage.
But I had quite often the situation where I need to do a little bit of programming during mix stage and the problem is always the same. Even when the project is heavily loaded with bunch of plugins on inserts and aux, MIDI timeing problems are exactly the same.
So, with or without plugin load, MIDI goes(what is recorded, not what play) usually, back of grid. And sometimes, ahead of grid. Randomly.

Maybe I need ghostbusters.

But the way you solved your problem is inspireing to me and I`ll try your method.

Thanks once more, Steve

This problem was happening as far back as C4. It is called “MIDI Drift”. There was a thread about it at least 2 or 3 years ago, and I had this problem but cannot for the life of me remember what the fix was. IN Windows, I think it was related to the system timestamp. After that, I finally put a bullet through tht PC and bought a MAC. Been happy ever since. I still get some drift but just attribute it my playing while recording. If you go to the Knoweldge Base and put in the phrase “MIDI Drift”, you might be surprised at what comes up. Preference files also I think need to be modified or trashed… SOrry I cannot remember.


Set your PPQs, this used to be found in the preferences menu not sure where they stick it now a days. I haven’t encounted this in almost 20 years first ran into when MIDI had to be sync’d using a MIDI sync box then I upgraded to an Atari and then ran into this again and it was because the PPQ’s were setup improper ie a Quarter note = 480
it might have changed but I am pretty sure you can find this in the manual. Set this number up in the PPQ values and this should solve your problem. I use MIDI for about 90% of all my recording projects and haven’t run into this in years so I hope this helps some.



Thank you guys, I’ll try everything solution today, when I’ll be in the studio. I wasn’t replaying,sorry for that,cause I was on longer trip. I’ve just opened forum and saw possible solutions for my problem. Really apriciate every efort from all of you.