Midi track looping issue

As said, I tried to reproduce from your picture as similar as possible, incl. Part triggers. The loop plays just fine forever on 2 systems here.
As a last resort, you might send a project (use the new “Archive” function, otherwise we don’t get the MIDI data). But I honestly doubt that that will reveal your problem, unless you also have plugins etc in the mixer.
Does the CPU display show overload? What is your buffer size (latency) setting? And is the behaviour always exactly the same? Any hint that helps to reproduce, thanks!

I tried to zip the project and its almost 10mb. Is there a way i can send that file to you?
I tried attaching it here and here it only accepts max 4MB.

But then you have loads of other stuff in your project.
Could you not reduce it to the one Song/Part with the MIDI, check if the problem persists? What happens if you save the project, delete all Parts except the one in question, is the problem still there? Then you should have a tiny project :slight_smile:

Archive.zip (878.6 KB)
I used the Archive function and its only 879kb.
I just checked the Archive also the issue exists in that too.

I don’t have a plugin on the drum track. But I had 3 plug on the “Track 1” track which is muted.
I tried disabling the plugs on “Track 1” and still the issue presist.
CPU don’t show overloaded.
Right now i was using my internal PC’s sound card, so am not sure how to check the buffer size.
(When using cubase projects I use my external sound card which i set from 512mb to 1024mb buffer size, depends upon load)

It looks like I can reproduce your problem now, will report, stay tuned and thanks again!

That is relieving to know…
Also am seeing lot of crashing happening and application exiting…
May be i will put this as another thread…

crashes are the very least we accept, so please send us crash reports (documents/Steinberg/Crash Reports, starting with “VST LIve”), thanks.

Yes it does and it helped a lot finding the problem, will be fixed with the next version. Thank you so much for helping. The problem only reveals itself with certain tempi, such as 70 in your case.

I hope you were able to replicate the issue in “Drag a instrument pattern from groove agent to midi track messing up the drum loop - #5 by tmat” thread also.

VST Live Version 1.1.10 2022.11.7 (454.2 KB)
VST Live Version 1.1.10 2022.11.7 (282.7 KB)

Todays crash report

@tmat, it has crashed inside your KORG M1 Plug-In. Do you have any contacts to KORG? Can you please contact them to see why it has crashed? Meanwhile we are diving to your other crash log.

Thank you,

… that one is fixed too. It happened with the MIDI Inputs color selector in the HUB (only for Windows). At the moment you need to select a color when the selector is visible. If not and you move on (Open Other, New Project, Cancel), it will end up in a crash or deal loop. Next Update.


Due to the many issues i was facing I couldn’t test the VST live software further, so i stopped testing until all the current issues were fixed in next version.
So will steinberg give more trial period in such case?

… please drop me a mail to m.spork ( at ) steinberg (.) de


Same issue. After some cycle, random, midi do not play. audio track play continue to play.
win10, ur44 steinberg, promachine, 128buffer, it’s the same. and high energy power cpu fixed, no cpu problems.

issue is fixed with the next version.


I just downloaded the new version 1.1.20 and i see this issue is not yet fixed.

Groove Agent drum Pattern not getting added to the bar properly and not playing in the proper timing set. Weird timing. Sometimes I don’t hear the sound also.

When i closed and reopened the project, the pattern fits the bar, but drums is totally messed up.


Attaching the project here.

TestProj.zip (71.0 KB)

… we found the problem and fixed it. Next update. Thank you.

… and this one is solved and discussed here. Let’s try not to get doubled entries. or we loosing the overview. Thank you.