MIDI track/VST instrument mismatch

Hi!

When loading a new VST-instrument from the Rack, Cubase asks whether it should create a MIDI track assigned to the instrument or not. If I choose “Yes” as I usually do, chances are that the newly created MIDI track gets assigned to a previously loaded VSTi instead which means that I have to manually change the assignment in the inspector.
Now, the worst part about this is that if I save a project containing lots of Rack instruments (i.e. an orchestral setup), close it and then open it again, chances are that more or less one half of all the MIDI tracks/VST instruments in the project will be mismatched upon loading resulting in precious time being lost while fiddling around in order to correct it.
Any ideas?

So many issues with C10 so far and many of them don’t seem to be addressed. This is worrying to say the least, if not totally unacceptable.

Hi,

Do you mean that once you save, close and reopen the project, the MIDI Out doesn’t match how did you save the project? I don’t believe so. There are some known issue (like this can happen when you Deactivate and Reactivate the track), but it works in the basic use case, I’m quite sure.

What kind of Instrument Rack VSTi do you use?

Thanks for trying to help me out, Martin.
Also, I’m sorry for the delay it’s been a busy week.

Exactly - Once I save and reopen the project, some of the MIDI Outs don’t match the VSTi’s the way they were created initially and sometimes Cubase makes a mismatch already when choosing the option to create a MIDI track assigned to a newly loaded plugin instrument as mentioned earlier.
However, I don’t quite understand what you mean by saying you don’t believe so? It’s not that I’m being delusional here and if this would have worked the same way it did in previous versions, I wouldn’t have posted this as an issue now, would I? Besides, Cubase has been my main DAW since 1998 so with all due respect, but I consider myself pretty familiar with the Cubase environment.
This has nothing to do with activating or deactivating the track, it happens randomly whenever I save and reopen a project with lots of VSTi’s.

I use Kontakt 6 a lot (latest version) and have also been using HZ Strings by Spitfire Audio quite intensively in tandem with Kontakt lately and the same mismatch occurs with both of them.

Hi,

NI Kontak has the multi-MIDI ports feature. So you can use me than 16 MIDI channels, right? Do you use it?

I’m creating multis by loading up a maximum of about 10 patches, together using approximately 6-7 MIDI channels as per Kontakt instance. Also, since switching from C8 to C10 I haven’t yet used any of the additional audio outputs in Kontakt, besides the Stereo main.

I also notice a mismatch of MIDI channels in my VEPro Setup. Channels get mixed up. Cross over. It is really annoying and I noticed it since C9 I believe

I’m not the only one apparently. That’s reassuring. :wink:
So, does someone have any idea how to correct the problem or should we consider it as yet another bug?

Hi,

Did you Disable the track or instrument?

Isn’t it related to Missing MIDI output after Instrument track disabled/enabled or Midi output routing change when disable enable midi track.

Hi again Martin,
Thanks for the link, but the answer is no. There are no tracks or instruments that are disabled, or have previously been disabled in the projects affected by this issue whatsoever.

hey Martin
in my case I am not sure.
I use 3 VePro clients which are in hybernation when not used.
After reactivation of the slaves I usually load the project in Cubase.
It is strange though that not all of the slaves instances on one client are affected which would make sense if there is a general connection problem.
I am still looking for a way to reproduce this but it’s not happening everytime :-/