Midi triggering external MOFX out of sync after upgrade to Pro 9

So I upgraded to Cubase 9 Pro from AI 8. I had a song with one midi track triggering drums on a Yamaha MOFX and another instrument track of HALion drums using the same exact midi data copy and pasted that I created with AI8.

After the upgrade, the MOFX track is triggering slightly ahead of the Halion track and they are way out of sync. But when I open it up in AI8 they are perfectly in sync. Why does 9 mess it up??

And the Halion track is definitely the one that did not budge because it is still in sync with the other audio tracks in the song, so its definitely the MOFX track that got messed up.


Are you on Mac or Windows?

Windows 10

Also I am using a Focusrite 6i6 (2nd gen) as interface and driver in Cubase.

Is it possible it’s this issue?

OK I found the problem.

I put a multi band compressor on the output channel in Pro 9 that wasn’t in AI 8. After taking it out the tracks are back in sync. But what does this mean? Why did the compressor cause the mistiming? Again the compressor was applied to the output mix, not the MOFX track individually.

Is the multi compressor a resource hog which is causing a delay for all external instruments? What would the fix be?


Multi Compressor causing delay of all output signal. But thanks to the internal delay compensation, all tracks should be delayed, even the MIDI tracks.

So if all tracks should have compensation something is still amiss yes? The midi Halion track is fine but it is the tracks that are triggering the external keyboard that are the problem. Is there a setting or something I should look at to try to fix this?

Do you send common MIDI Notes to the external keyboard?

Yes, it its the same exact midi data copy and pasted between the Halion and MOFX.

Do you use an External Instrument in the VST Connections? Isn’t there any delay set?

Sorry I’m a bit of a noob but this is how I’m using the MOFX as shown in the pics attached.

When I go to External instruments in VST connections the MOFX is not there. Does it need to be there? I assumed the Yamaha/Steinberg integration took care of all that.

Also when I just bypass the multiband compressor on the Stereo Out the problem still exists. When I deactivate the compressor the problem goes away, as with removing it from the slot altogether.

Do you use MOX Editor? Or is it an External VST Instrument?

Problem solved…I was direct monitoring the keyboard instead of listening to the returned audio.