midi volume automation track does not affect the volume

This is a stupid question I should know, but the volume automation track does not affect the volume on a particular midi track. I have been controlling it from the VST track but would like to adjust it just from the individual midi track. Am I missing something in Cubase or is it something in the VST itself?
Thanks

Hi,

There are multiple “Volumes” and also “representants”.

Did you use a MIDI or an Instrument Track? Did you use Volume or MIDI CC 7? Did you send it from the automation track or MIDI Editor? Does the fader move?

Hi Martin,
Thanks for the quick reply, I tried both midi track and instrument track with the same effect. I only show “Volume” under the midi track and CC-7 is not listed in the CC menu. And yes, the volume fader moves.

Hi,

So the fader moves, but the audible Volume doesn’t change? Could you describe the routing, please?

What is the VST Instrument in question, and are you certain that it responds to MIDI CC#7 (not all VSTis do by default :wink: ?
Try drawing a MIDI CC#7 curve in the Key Editor.

Hi, I have exactly the same problem. It is April 2020 ans I have just updated my Halion Sonic SE3 with the lastest version.

I can not control the volume of programs in Halion SE3 from Cubase. I have a few instruments on different MIDI tracks of the Halion VST instrument, each set with a different Output in the Mix panel of the Halion Sonic SE3 editor.

When I move the volume fader of a Halion midi track in Cubase, nothing happens (volume stays the same). Only when I move the fader of an Halion Output track in Cubase mix console (like HSSE out2), I can hear the volume change, but the change in the volume does not reflect in the Halion Mix panel for the program.

How can I automate the volume of my Helion program then?

I am also using NI Kontakt with Cubase, and I don’t have any issue, I can change the Volume of my different Kontakt instruments via MIDI tracks in Cubase.
I find hard to believe that the same is not possible with Halion. There might be something I just don’t get?
Thanks for you help.

Hi and welcome,

Use MIDI CC 7 (Volume) on the specific MIDI Channel.

That is precisely my problem. When I modify/automate in Cubase the volume of a midi track linked to an Halion instrument using cc7 or by moving the volume fader of the midi track on the MixConsole, it has no effect whatsoever on the volume of the Halion sound. Same with pan. In Cubase, I can see the Volume values change according to my automation but that does not have any effect on Halion and its volume does not change.
I really don’t understand what I am doing wrong. Again, it works fine with Kontakt vst intruments.

Hi,

Could you attach a screenshot how do you do it, please?

So I have attached screenshots of my project:
Cubase project, MixConsole, Halion Sonic SE Midi.
Halion Sonic SE-Midi.jpg
MixConsole.png
Cubase project.png

And Sonic Halion SE Mixer and Options windows
Halion Sonic SE-Options.jpg
Halion Sonic SE-Mix.jpg

Hi,

Do you use the Automation curve in the Project window? Why is the Automation Read enabled? Or do you use the MIDI CC automation in the Key Editor?

I have been using both and none worked. I guess I just forgot to disable Read but it has no effect whether it is enabled or not. The only way for me to change the volume of the Halion instruments is to move the light green faders connected to the Stereo Mix in the ConsoleMix (not the yellow Midi faders), or change the levels directly on the Halion Mix window.