MIDI Volume Erratic

I have two MIDI keyboards: a Yamaha Montage 7, and a Yamaha Piaggero NP-32. I have been using Cubasis 3 with the Montage until today. But the point of my use of Cubasis is to have a portable rig, so today I started using the Piaggero instead.

One of the MIDI tracks in the project is set up to accept MIDI input from the keyboard and route it back out to the keyboard to use the sound that the keyboard can generate. Local control on the MIDI keyboard is set to Off. This works fine with the Montage, but there’s a problem with the Piaggero.

When I play the Piaggero through this track, the volume I get back out of Piaggero speakers is randomly inaccurate. Most of the time it’s fine, but every five or six notes the sound comes through really loud. This happens with the Piaggero, but it does not happen with the Montage. It happens with Cubasis 3, but it does not happen with Cubasis 2. So I will have to switch back to Cubasis 2 until this gets fixed.

iOS 13.3, iPad Pro 2 12.9”, Cubasis 2.8.2 and 3.

The Cubasis project is attached.
Limbo 2.zip (9.46 KB)

Hi mtrigoboff,

Please send us a short detailed setup description to recreate your routing settings.

  • midi I/O
  • devices I/O
  • midi interface


thank you and best regards

In the process of getting the information you requested, I discovered some more details.

The problem occurs when the settings for the track are as shown in Volume Problem.png. The crucial setting is MIDI output set to All. When MIDI output is set to Ch 1 instead, as shown in Volume No Problem.png, the problem does not occur.

Furthermore, the problem isn’t as random as I thought. It occurred while I was playing in a particular place on the keyboard. If I play the following sequence of keys, G3 A3 B3 C4 D4, it’s always the B3 and C4 that play too loud, while the rest play as expected.

So as a result, I have a workaround, and my suspicion is that it’s actually something weird with the Piaggero, and not a problem with Cubasis 3 after all.

The iPad is connected to the Piaggero via an Apple Camera Kit adaptor and a USB cable.

Thanks for your inquiry, and please let me know if there’s any other information I can provide for you.

And, Merry Christmas.

Forgot to mention: Piaggero MIDI In and Out both set to Ch 1.