Midi Volume Filter (Help ?)

Hi folks,

i would like to 100% completely disable Cubase from Receiving VOLUME CHANGE please.


Method :-

File > Preferences > Midi Filter.

Then i ADD CC# 07 to the Controler panel list.


Problem :-

Volume Change is still being received !!


Question :-

Is there anything else i can turn off or filter out to successfully disable Volume Change ??

i do use Mod/Pitch Bend/Aftertouch/etc so i can not literally turn everything off.


(i am using a MIDISPORT 2x2 Midi to USB merger, so a regular midi lead from Nord Out to Midisport In, and then a USB lead from the Midisport Out to PC In. i am not sure if this could be a possible cause of the issue ?? i have the latest drivers etc).


Thanks,

Paul

Is anyone able to help me with this issue please as i have spent another couple of days on it and have totally run out of ideas now !! :confused:

Ta.

I see this is still a problem for you. I thought someone might have jumped in to help.
If activating the midi filter in prefs is not working, something must be wrong.

  • Did you press ADD and OKAY?
  • Are you really sending #7 Volume. or something else?

You can also filter this using the “input transformer”. Kind of complicated to use, you can read the manual and see if you want to delve into that tool. It has presets in its menu. But I don’t think you need to if you can make it work the first way.

I guess you have checked out if your NORD can stop sending volume info on the global level.
Finally, as you have described it, your keyboard only sends the volume message when you change programs. Do you actually change programs while recording?

Hi Phil,

Thank you very much indeed.

i spent a whole week working on the Nord, posting threads on the forum, and contacting Technical Support.

In order for me to answer your questions, i need to breifly explain about how the Nord works :-

Basically, the Nord has an External Section panel which controls external devices such and sound modules etc. It has multifunctioning dial which can be set/changed to control either Volume, CC#, or Program Change on the external device. However, i want to use the External Section to be able to trigger the sounds within HALion but do not want to transmit Volume, CC#, or Program Change. Now, the strange thing is that when i transmit CC# or Program Change from the Nord (just to try it out) Cubase ignores the data because it obeys these two particular Midi reception settings in the Midi Filter page. But it receives and responds to the Volume Change messages coming from the exact same External Section on the Nord ?? Even if the Nord transmits Volume Change then surely Cubase should be ignoring it because it has been filtered out !! So thats whay i am thinking it is something within Cubase which needs to be set ?? i will have a look at the ‘Input Transformer’ you kindly mention. This is something i have not used or heard of.

i have managed to solve the problem of the Nord transmitting Volume Change during the changing of presets. There is an option NOT SEND ON LOAD which means the Nord won’t send out any Program Change, CC#, or Volume Change everytime a new preset is selected. However, once the preset has been selected if i accidentally nudge the Nord Volume dial then the Volume slider(s) in Cubase are disrupted.

i do not use Program Change in Cubase because if i need a new instrument i just open up a new Instrument slot in the HALion Multi Rack. And if i want Control Change then i set the track to Read Automation and adjust the appropiate Cubase parameters with my mouse.

In case you are trying to work with use the input transformer, here is a screen shot of how I got it to filter out the volume data.
Screen Shot 2013-02-24 at 4.17.10 PM.png

Hi Phil,

Thanks that most helpful indeed.

Now, i applied the INPUT TRANSFORMER to my project. i have attached the Cubase File but i am not sure if this site will permit the uploading of such files as i have never done this before. Anyway, hopefully you will be able to have a quick look at it.

The recording :-

i have 4 x Midi Tracks (using HALion and the Prologue) as VSTi’s. The Input Transformer icon is ON for these 4 x tracks. And the Midi Volume (being transmitted from the Nord) is NOT being received by these channels at all !!

The other 2 x tracks are Audio Tracks (1 x Nord piano patch, and 1 x Roland XV-5050 saxophone patch). These 2 x Audio tracks DO NOT have the option (as far as i can see from trying and reading the manual) for being applied to such Audio tracks. And therefore the Volume Change from the Nord is still being received by these 2 x Audio tracks !!!

i appreciate your help…
Midi Volume.cpr (289 KB)

Okay, we are getting somewhere.
Audio tracks don’t record MIDI, so you are not recording MIDI volume, and you can’t filter it out, either. The audio clips were not in the file, but I do believe the levels are going up and down. But this seems to be how the audio is going in to Cubase. When you record the nord audio w/o midi cable, it’s fine -right?

(The transformer is just for MIDI information.)

The Input Transformer settings seem to be more more powerful than the ones in Midi Filter in that they over-ride its settings. It has cured the problem with Midi tracks receiving Volume Change. None of the Midi track volume sliders are now affected.

Ok, so the Input Transformer can not be applied to Audio tracks. When i turn the Volume dial on the Nord External Section the slider on the Cubase mixing desk channel of the Nord (Audio) physically moves up and down. It is precisely this which i can not seem to stop.

i have not tried recording the Nord without a midi cable. i come out of Midi Out on the Nord into Midi In on the MidiSport midibox (with a regular midi lead). Then the USB Out of the MidiSport into my PC (with a USB lead). This is because the Nord Stage Classic does not transmit Midi over USB (hence the need for the MidiSport to cater for the commication and cable conversion). If you are going to suggest removing the midi cable everytime i want to record Audio (which will of course eliminate the problem of Volume Change being transmitted to the Audio tracks), this is going to prove problematic because often when i remove such a cable my PC detects it and Cubase freezes. This is because it can’t cope with something which WAS there being taken away (if that makes sense). The only reliable method is to close Cubase down and restart is again. So it reboots from fresh and recognizes which cables and devices are connect etc.

How do i export the Cubase project files so that they contain the audio material (so that you can hear/play the complete track) ??

Look in Devices > Device Setup
and look at the Generic remote and Quick controls. That’s my hunch. Check out chapter 27 “Remote Controlling Cubase”.
Someone will have a very simple answer for you, I’m sure. You will get this sorted out.

If you want to recoird audio, you need to make an audio connection from your Nord to your soundcard and either record the audio output in realtime, or use the “external instrument” feature.

Am i not doing this already by recording the Nord as AUDIO via 2 x jack leads running out of the Nord into the CI+2 soundcard ??

What is the External Instrument feature please ??

Did you mention that somewhere, or how am I supposed to know that…?
And if you are doing it already, then why are you asking what to do to have the export containing the audio material…?

It’s explained in the manual.

i don’t know what you are talking about.

If you had read the thread properly you would see i wanted to send a very helpful member a Cubase file containing all Audio/Midi data so that he could check the issues i am having.

Please do not post on this thread anymore. Thank you.

If you had read the thread properly you would see i wanted to send a helpful member a file Cubase containing all Audio/Midi data so that he could check the issues i am having.

I think I read the thread properly, but I still can not see that anywhere…

7 x posts back (to Philskeys) :-

How do i export the Cubase project files so that they contain the audio material (so that you can hear/play the complete track) ??

There´s probably no need to discuss that any further, but from that I personally can´t see you want to send something to someone. I read that as a question, how you export a project-…, -…so someone can hear … I also did not see you´re “talking” to Philskeys exclusively. Probably my fault…

i had a look thanks. i think what this menu can do is very intricate. What i am not sure about though is if i alter some of the settings here, then will they be altered this way in EVERY past and present Cubase project, or just for this particular project ?? In other words are these GLOBAL settings which affect everything thereafter, or (as i said) just settings exclusive to this particular project ?? So that (hyperthetically) you can have totally different Generic Device settings for every project you create ??

What i am thinking is, is that i could pinpoint the Nord Volume dial within Cubase, and then RE-ASSIGN it to a parameter which i don’t use at all. For example, at the moment the Nord Volume dial is triggering (quite correctly) the Volume slider on the Cubase mixing desk for the Nord Audio channel. Within the Generic Devices i think i might be able to change it from triggering the Volume slider to something like turning a parameter on/off with a dummy CC# (i am sure there are some CC#'s in Cubase which are blank). At the moment it is set to #07 (Volume) and so it would just need changing to a CC# which is null.

What would you think about that being a possible solution ??

i just got a full reply off Nord Technical Support who have confirmed that i am correct in all my assumptions and experiments (it took me over a week but at least i know i am correct !! ha ha). The Nord External Section is designed for controling hardware synth modules in a live performance setting and not really for DAW. And so it is impossible to disable the Volume dial transmission !! Therefore, it needs to be done at the Cubase end.

The Generic Remote page in Cubase is exactly where the settings need to be made. i managed to disable the reception of Volume Change here !! It took a bit of experiementing but i think i have got it now. However, it has given rise to a couple more questions.

By default, the assignment of each FADER is set to VST MIXER (and so therefore the Cubase mixing desk slider moves alongside the altered dial on the external controler, as you would naturally expect). So anyway, on the Generic Remote page if you click on each FADER (1~16) and change the DEVICE from VST MIXER to NOT ASSIGNED it seems to cure the issue. However, i am not sure how reliable this is and if it is the ultimate solution but it does seem to work (whereas not other method as yet has worked whatsoever).

On the FADER selections which i changed to NOT ASSIGNED the CATAGORY and VALUE/ACTION boxes are now blank. No problem.

But when i change the FADER assignments back to what they originally were (ie. click on each FADER and re-assign it back to VST MIXER again) i am unsure about the data in the VALUE/ACTION column ?? Before i changed the assignment (and on any other columns where i have left the assignment set to VST MIXER, such as all the FX CHANNELS), the VALUES are all set to ‘1025’. In other words, when a FADER is left set to VST MIXER the VALUE/ACTION is at a default ‘1025’, but when the FADER is changed to NOT ASSIGNED and then changed back to VST MIXER the VALUE/ACTION changes to ‘minus 1’ (ie. not back to '1025) !! Does this matter ?? i ask because once i have changed the ASSIGNMENTS (and the VALUE changes to ‘minus 1’) i don’t seem to be able to put them back again to ‘1025’ (ie. when i re-assign each FADER back to VST MIXER). The VALUE here remains at ‘minus 1’ and i can’t set it back to ‘1025’ !! ??

i also wondered what the value ‘minus 1’ represents ?? Does it mean OFF because Volume Change is not being received in this instance ??

Do you really want the Nord to be used as a remote controller for Cubase? Sounds very confusing when it’s also a MIDI master keyboard and sound module. It means that one synth control (volume) not only changes the actual audio output of the synth, but at the same time the fader in Cubase. I’d say remove it as a remote ctl device and keep things straight forward.

i thought it would have been much simpler to set up than it has proven to be.

The thing with the Nord is that the touch of the keyboard is excellent and it is 88 x notes.