MIDI/WAV sync issue

I recently tried to create a single 4 minute MIDi drum track by playing the drum pad live to a previously recorded WAV file. If I play back the two tracks from the start, the MIDI and WAV tracks stay in sync to the end. However when I start from a position towards the end the two tracks are out of sync. Also when I did a mix down, the sync issue gets worse the longer the file is played.

My work around was to re-record the MIDI drum tracks as several shorter chunks (each with a different track), then overly them all onto one track. Very time consuming! [post note : the sync slips even doing this sometimes]

IPad Pro (latest) with IOS 12.1 and latest Cubasis 2

Hi softbass,

Thanks for your message.

If possible, please provide me with the project plus exact step description*, so we can give the issue a check.
Please upload the files via Dropbox or similar, and let me have the download link via private message.


  • Bug Reporting Form
  1. Summary/Title
    (Provide a short but descriptive sentence that summaries the issue or feature request)

  2. Description
    (Provide a detailed description and list the step by step process to reproduce the issue to help the team to understand and reproduce the problem)

  3. Expected Results
    (Describe what you expected to see)

  4. Actual Results
    (Describe what you actually saw)

  5. Environment
    (Count the hardware and software including version numbers being used)

Ok, Lars. I’ll send you a video capture (with audio) soon. It shows the problem the other way round where playing back the long live recorded MIDI drum track through to the end shows no problem with sync, but then if you reply the last minute of the recording, you’ll hear the sync error between the MIDI and audio track.

It also shows the problem with trying to record a drum track to someone who has recorded without using a click track…lol. :wink:

Hi softbass,

Thank you for providing the files via private message.
Please have a look at our reply, sent via private message as well.


Hi Lars,

Any luck with this one?

I would imagine quite a few musicians like to record songs in one take using audio tracks and MIDI tracks (e.g live vocals and live MIDI drum kit). This accumilative sync bug between long audio and long MIDI takes makes recording in this way unusable.

I would imagine it’s not an easy problem to address as the MIDI clock is different to the WAV sampling clock. I was wondering whether in the code it is possible to resync the MIDI clock to the WAV sampling clock at regular intervals during long recordings. Effectively breaking up long MIDI recordings into smaller chunks. I suspect there is a drift even over shorter intervals but that is unlikely to be noticed by most people.The drift over 3-4 minutes is very noticeable though!

Hi softbass,

Thanks for your message.

As of yet, we’re unable to reproduce the problem.
If possible, please provide us with further details.


I’ve already provided you with a YouTube video showing exactly how to reproduce this bug. Every step is shown on there.

Hi softbass,

Thanks for your message.

If I remember correctly, the previous repro provided showed a few recordings without playing to close to the metronome.
So far we were unable to reproduce the problem, following a similar pattern in our repros.

Best wishes,

So you blame the user then close off the bug report. I’m so glad now I decided not to become a Beta tester for you guys. I’m also not surprised you wanted me to sign an NDA.

Hi softbass,

Be assured that it was not my intention to blame you.

Reproducible cases are helpful and required to evaluate and solve bugs of this criteria.
Given your example it was hard to track where the sync problem appeared (which has to do with the fact that the project contained a humanised recording).

I’ve created a similar example with a quantised drum track (both MIDI and audio) running with the Cubasis click.
Unfortunately we weren’t unable to identify sync issues listening to the playback here.

We did not close the bug report.
Please get in touch if you’re able to provide us with more details or another repro which clearly shows the problem.

P.S.: Exchanging non-disclosure agreements is common practice in our business, since we often share beta versions and/or new unreleased products with externals. Nothing to worry about, and common practice for many other vendors like us.


In the second example I gave you (on YouTube) the audio track was made up using repeats of a drum loop provided by in Cubasis. This obviously wasn’t recorded by me using a click track as it’s an audio loop.

Then I simply recorded the drum MIDI track to that audio track in real time. As I was playing to a repeated audio drum loop I didn’t need a click track for that either, the loop was effectively my click track.

It appears you haven’t repeated the test using the same conditions as I did. I did not need to use a click track. You seem to have performed the test using a click track.

To put it simply, if you use Cubasis as you would an analog multitrack tape recorder (i.e record without using a MIDI click track) MIDI tracks drift from the audio tracks over time on playback. During recording no drift is noticed.

For background. This bug was discovered when I was asked to add a MIDI drum track to a prerecorded audio track of someone singing and playing autoharp which was not recorded using a click track. I did my best playing the MIDI drum track in time to it, However the drift between MIDI drum track and audio track was noticed on playback as the song went on.

For me, Cubasis should be able to work in the same way as a multitrack tape recorder without having to rely on a MIDI click track. MIDI Tracks should stay in sync with audio tracks regardless of them being recorded to the MIDI click track.

Hi softbass,

To avoid misunderstandings and to reproduce your topic exactly, we need an short step by step description.

If i am understand you right :

  • create an audio track and assign audio input from external audio device ( eg. Vocals )
  • create midi track and assign midi Input from external midi device ( Motif > Midimate II (Midi Interface) > iPad > Cubasis Midi Input
  • start recording midi and audio simultaneously for 10 minutes
  • start playback after recording one midi and one Audio track
    Result : The recorded midi data does not synchronize with the recorded audio data and vice versa.
    The longer the playback, the greater the offset between the recorded midi and audio data.

Is this your usecase ?

best greetings

No it’s not the usecase at all. I sent you guys a link to a second video I made showing what I did step by step. I can only assume you haven’t seen it. Here is the link again…

I also believe I have given enough information above for anyone to reproduce it. It really is not hard to reproduce but as the sync issue can only be seen after a few minutes it takes some time.

Hi Softbass,

Thank you for the Video again !

Unfortunately, we can’t reproduce this with

  • iPad Pro11, 2Generation iOS 12.1.4 + 12.2
  • iPad Pro, 1Generation, 12.9 inch, iOS 12.1.4

“Ultra Low” latency settings, 44 + 48 khz

Here is a link for my video, you can download it for 7 days.
I exactly recreated your case and test it several times.

All what is not in sync with cubasis is my Timing :blush:

Cubasis synctest download link until 06.05.2019


I’m guessing it’s your iPad + iOS or your latency Setting.
Attention : With iOS 12.1 there were some heavy sync + cpu problems only with the iPad Pro from october 2018

Please send us your Detail iPad + iOS Version.

best greetings

This seems to have been fixed in Cubasis 3!

Hi there. I also have heard about it. I hope it is true.