MIDI went totally crazy... need help

Hello! :slight_smile:

I wanted to see if someone could help me out with this one…

My MIDI recording went totally crazy, when I´m recording, whenever I input any MIDI data it kinda quantizes to whatever I have on my quantize bar but quantize is turned OFF and does not respects how long or short my note is (that´s the quantization, I guess). I tried everything, reading the manual, checking all options off on automatic quantization in the midi under the transport bar, step input is off, and also quantization.

Here´s a video of this issue:
https://youtu.be/U-yCTDrjkEU

Any idea how to remove this?

Thanks!

I tried to replicate that but couldn’t. I have been working with MIDI for almost as long as there has been MIDI and have never seen that before.
Perhaps it may have something with the MIDI controller you are using? What is you hardware and how do you have it routed.

Hey, John!

Managed to fix it! It was incredibly weird, I really don´t know how it happened… My guess is that some settings changed when I upgraded to a new audio interface last week and some settings changed?

It was fixed by going into Studio Setup—MIDI—MIDI Port Setup and Ticking the box Use System Timesnap for “Windows MIDI” Inputs, and un-ticking the box "Use Device “Direct Music”.

It´s a digital Roland piano RP201, connected through MIDI to a Focusrite Scarlett 18i20

I have no clue what these do… but It fixed it 100%!