Minor Bug with Staff Spacing dialog box

I just upgraded from 1.1 to the latest version of 1.2 (Windows).

Yesterday I could type “.44” into the staff spacing dialog. Today I can’t type a decimal point. But if I leave the existing decimal point “1.0” and replace the numbers to “0.44”, I can get around it. I think the key input filter for this dialog got a little too smart with the last update.

I believe you might need to add the 0 first. Have you tried 0.44"?


I guess I had not tried that. You’re right. I can type “0.44”. Thanks.

I still think I should be able to type “.44” though. It’s a legit numerical value.

I somewhat agree with you on that… but I ran into this issue recently as well, and learned that it needed the 0. and not just the .


Can you tell me which exact dialog you’re talking about? Thanks!

In staff spacing mode, doubleclicking on a staff spacing value brings up the dialogue allowing one to type in a numerical value.

In the latest version, the validation routine got a lot “smarter” and now disallows certain legitimate numerical values. You can’t type “.44” or delete the 1 in “1.44”. Now that I know its logic, it’s possible to work around it, but I don’t think there’s any reason for it to be that insistent on a particular number format.

I have noticed numerous places (frames and their distance from margins is another example) where Dorico will not accept a “.XX”, and that it only allows “0.XX” for a value when using inches for the measurement.

if you type “.XX” , I saw Dorico ignore the “.” and use the XX as an actual measurement. I am not sure if this occurred before or after the most recent update. But I did see this, and learned quickly that one must put the 0 before the decimal to make it work correctly.