Missing audio chunks on record

OK, so have had this problem since first installing Cubasis and others have reported it as well. That is, that on recording audio, chunks are missed out and the ends of the gaps butted up against each other so that you end up with jumps in the audio and several bars short at the end of the song.

Initially I thought it was resolved with v1.1 but it wasn’t, nor with v1.2 but it is intermittent, although fairly persistent at present. I have tried advice from others including putting the iPad into Airplane mode, quitting all other apps, rebooting before recording etc. I had also thought it might be due to the processor load from AmpKit+ and Audiobus running at the same time. However problem still occurring with only Cubasis running with its own Amp Simulator. Also this is the first take recorded in Cubasis so no playback load etc.

BeatMaker 2 seems to work perfectly with AmpKit+ and Audiobus.

I have a 64Gb iPad 2 patched to IOS 6.2, with about 1.6Gb free.

Is it only me or is anyone else experiencing this still or have any thoughts?

I haven’t yet tried deleting and reinstalling Cubasis but figured that with the upgrades that shouldn’t be necessary - worth a try?

I had a period in version 1 where I had a few consistent bugs showing up. The 1.1 didn’t fix it like it was supposed to so I backed up my project files and did a complete delete and re-install. It solved the problem. Unfortunately this is sometimes a necessary step if all other fix attempts fail to resolve the issue.

Thanks for that. Tried a delete and complete reinstall, reboot iPad, Airplane mode, Cubasis as only app running and record into fresh project. Whilst it’s better, I’m still having the issue. Losing about 1-2 beats out of 25 bars. The only other variable I haven’t mentioned is that I’m using an Apogee Jam as the guitar input.

Anyone have further ideas?

Going through previous thread on this (Recording and Mix Issues) noticed that BruceSwanson was also using an iPad2 and Apogee Jam but not sure if he’s still experiencing problems - anyone else using this hardware combination successfully?

And my earlier post should have said iOS 6.1.2 lest anyone think I’m a complete goose. I note the Apogee Jam is approved hardware. Any thoughts from Frieder or other Steinberg folks? This app is unusable for me and I’m thinking of asking for a refund. Plus I shelled out $500 for Cubase 7 because of the compatability…


please excuse the delay in answering. We will test your setup beginning of next week and let you know about the result.

Kind regards,

Thanks Frieder, appreciated. As mentioned previously, the only other thing I can think of is that there’s not a huge amount of free storage on the iPad (2.1Gb) but I wouldn’t have thought this would be an issue. Would there be anything visible in the crash logs? Look forward to hearing from you.


we tested your setup. We used the same interface, an iPad with little remaining storage, and tried stressing it as hard as we could during recording. However, we did not experience missing audio. Could you send me a file in which we can hear the issue? This would certainly help us in identifying the problem.

Thank you and kind regards,

Thanks Frieder, will do.

Hi guys I am experiencing very simillar problems…

Ipad 2 alesis idock (latest firmware) Ios 6.01

If i try to play Futelele or ifretless bass into Cubasis thru AB ,all will sound well during recording ,but when I listen back ,the track start running more and more out of sync the further it gets from the begining.
Any Idea?

Sort of glad it’s not only me. I have sent a file through to Frieder to have a look at.

Hi, I am experiencing similiar issues here as well. I record a jazz band during rehearsals and have small ‘holes’ in the audio. Seems to jump a tiny bit forward. It happens almost at every recording/track 1,2 or 3 times.
My setup is very simple. I use a Tascam iM2X stereo condenser mic plugged directly into the iPad.
I did not notice all of this when recording tracks with my Line 6 Mobile Keys 49 with the on board keyboard sounds of Cubasis. I also have an Alesis IO Dock but didn’t try so far with Cubasis. Garageband gives no problems there.


Hi Hans,

Do you have an iPad 2 or 3 or 4? Other people experiencing this seemed to have iPad 2s and I’m wondering if it doesn’t have quite enough processor grunt to keep up with audio recording.



Have upgraded to Cubase v1.3 and still having this problem. Sending another recording to Frieder. Can anyone with an iPad 2 record audio successfully?

Just an update. I noted in my original post that I only had about 1Gb free. I coincidentally deleted a bunch of photos to create about 5Gb free space and the problem seems to have disappeared. I haven’t yet tried filling the storage back up but and retesting I’m wondering if this might have at the bottom of the problem. Anyone else?

Have now run a test by filling up the iPad with photos so there was only 1Gb free - recorded guitar with no effects and got the glitching effect. Deleted the photos to 4Gb free and tried again; no glitching. My hypothesis is therefore that limited memory creates problems in writing to it which provokes the glitching. Would be interesting to know whether this was at the root of others’ problems.