Missing font dialogue in 4.3.11

Please see the Missing Font dialogue that is new to this Sometime Ago project in 4.3.11 but didn’t happen before in 4.3.10
Sometime Ago (F).dorico (1.1 MB)

I reinstalled Notation Express templates in the hope that the fonts would be found there after upgrading Dorico. No joy.

Please note also that if I then drop in the (uploaded) Jazz Quartet template to the Library Manager the Options section is now greyed out. Maybe related to above issue?

Jazz Quartet (Both saxes).dorico (758.5 KB)

There is no Petaluma Script Italic font. Edit the font style that is set to use the Italic style of Petaluma Script, and that should take care of that one.

PetaChords, PetaText and Pori Rehearsal Enclosed are all non-Dorico fonts. The fact that Dorico can’t find them is nothing to do with Dorico, I’m afraid: you’ll have to sort that one out on your own.

I have Pet* and Pori* finds installed on my Mac,so no problem.

But … I have been through every Font Style, Paragraph Style and Character Style and they all use a Regular style. But the Missing Fonts dialogue says that it can’t find the Font Style Petaluma Script Italic.
Even after I use the dialogue to specify the replacement as Font Style Petaluma Script Regular, on opening the project subsequently I still get the Missing Fonts dialogue again.
AFAICT all the fonts in the projects scores use the Regular style fonts as expected.
Something is not quite right.

This seems to make no difference. The dialogue will come up the next time I open the project.

If you have not changed the font/paragraph definitions of the fonts themselves, the error message will likely recur. Choosing Regular on the pulldown you show presumably only substitutes the style within the current editing session, not permanently.

In this particular project, the reason the dialog is appearing is because the now-deprecated bar numbers font style is set to use the italic flavour of Petaluma Script. Dorico shouldn’t warn about that specific font style because it’s no longer used. I’ll make sure that it doesn’t appear in future.

1 Like

I’m having this issue with pretty much any file I open since upgrading. Attaching a screenshot, and it doesn’t even seem to know what font is missing (“Source Sans Pro”). At first I thought it would only be an issue for files created in previous versions, but this particular project was created since I upgraded (NOTE: This is a recovery file because my work laptop restarted for updates before I saved it).

I get this same Missing Fonts dialog with every file I’ve opened since upgrading yesterday…about 6 so far. All the fonts are still set to the default Academico font, and even when I choose that in the Replacement option, the next time I open the file I get the same error again.

You can turn the dialog off in the preferences.

If you’re confident that all of the Font Styles and Paragraph Styles that you’re using are set to ‘actual’ weights and styles of the typeface that you’ve assigned, (and that those styles and weights are installed and active), then all is well.

Yes, but I’d rather solve the issue than just hide it. Obviously something is telling Dorico these documents are using fonts that aren’t installed, even though they aren’t. Down the road, if I get a file that DOES use fonts I don’t have, I’d like to have that warning.

I imagine that for some reason the Source Sans Pro fonts that are installed along with Dorico have been removed on your system. You can download the family here. Install them by unzipping the archive and then dragging all of the fonts into the Windows Fonts folder.

I had the same problem (missing Source Sans Pro font family) after I upgraded for 4.3.30. I went to Source Sans Pro - Google Fonts and selected Download Family. I unzipped the file and installed the fonts. That fixed the issue. To install the fonts in Windows, right click one of the fonts you unzipped and choose Install from the popup menu.