Missing Fonts message

Hi all,
When I open projects, I often get a Missing Font warning. This started happening after upgrading to 3.5.
Is there something I can do to fix this please?

Darren

Dorico’s Font Styles and Paragraph Styles ‘cascade’ – that is, they define themselves as ‘like that other style, but with these differences’.

If you change the Default Text font, it is possible for some existing Styles to be set to something like “the new Default Text Font, in an Italic Style”.

If your choice of font doesn’t have an Italic (or whatever), then you’ll see this message. For instance, Petaluma Text doesn’t have an Italic.

In short: it’s not complaining that some of your fonts have disappeared; it’s complaining that some of the Style settings are set to values that don’t exist.

Sadly, it doesn’t tell you exactly which of the Font Styles or Paragraph Styles are affected. It’s possible that you’re not even using that style in the current project. So just have a search around the Font and Paragraph Styles that you’re using, and check that the selection is valid for your Fonts.

To piggyback off of Ben, another issue is that Dorico defaults to “regular” as the default font style. Many fonts are not defined this way. I use Iowan Old Style as my default font and its standard style is defined as “roman”. Every single project I open gives me a warning about fonts even though the font is there, because Dorico wants a bunch of cascading styles to reference the “regular” which doesn’t exist. If the font in question is indeed installed, you can just click OK without changing anything or making any substitutions and it opens just fine.

Thanks for the advice, it somewhat clears things up. I really appreciate it.

However, I’m only using the default music fonts installed, Bravura and Petaluma. Nothing fancier than that, although I have increased the size of chords symbols in some projects. Don’t think I’ve selected anything in italicised font or something else.

Anyway, it doesn’t seem to be much of an issue as you’ve both described.

Regards

Darren

If, for instance, you set Petaluma as your default text font, and you don’t change (e.g.) your bar numbers font, you’re going to get the Missing Fonts Dialog. The bar numbers font(s) cascade from the default text font but with the “italic” style set. Petaluma doesn’t actually have an italic variant so Dorico (or possibly the operating system) synthesises one on the fly.

The point where this can cause problems is when generating PDFs; PDFs can’t embed font styles that don’t exist.

I believe I imported a file as an xml from Sibelius and get the following message when I load the saved file in Dorico.


I think there is supposed to be a ‘dropdown box’ to pick a replacement font family or style, but one does not appear when I click on the box. (version 3.5.10). Is there another place this can be done?

To the best of my knowledge, the fact that it’s a MusicXML file is irrelevant.

You may have changed the font for Default Text in Engrave > Paragraph Styles or the Default Text Font in Engrave > Paragraph styles, or possibly (probably?) the global one within Dorico Preferences.
Whichever it is, change it to a regular text font. Bravura is a music font, is not designed for text, and definitely doesn’t contain a Bold style.

Once you’ve changed the default fonts, close the existing project and reimport the MusicXML.

I’ve already made the changes to the file in Dorico. If there is no way to change the font in Dorico, then I will just ignore the message. The program is automatically assigning fonts that work.

The two fonts to change (assuming you’ve not been through and edited loads of the others manually) are the two defaults I mentioned in Engraving > Paragraph Styles and Font Styles.

If you fix these you shouldn’t need to reimport anything.

If the change you’d made was in the Dorico Preferences dialog, your best bet is to change that too, as that will affect all future projects you create/import.

Most of the other font and paragraph styles inherit various (most) characteristics from the defaults. For instance, Bar Numbers inherit everything from the Default Text Paragraph Style apart from the size and the style (which will be italic unless you’ve overridden that manually).

Early on, I would manually modify the chord symbols in Engrave mode to make the numbers larger (i.e. #5 or b9) . That turned out to be a bad idea because it would crash Dorico. After some research, I discovered a chord symbol set already in Dorico that had larger numbers and I now use that as a default. I say this because I notice the fonts in this lead sheet are quite large and may have been why this one font is a problem. When you load this file, you will notice there is no dropdown box to replace the font. The online help shows a picture of a dropdown where one can replace the offending font with an existing one.
I have not had any problems importing files for a while so I no longer consider this a problem, but I wanted to make you aware of the issue.
Shadow of Your Smile Leadsheet.dorico (1.1 MB)