Missing Key Commands

Where has the Key Commands in the Commands list disappeared to? When I try to program a new button all I see is a Commands list with a single entry “”!

The already programmed KC buttons seem to work correctly. I just can’t program any new ones. It looks like IC Pro no longer can read Cubase’s Key Commands list.

Dear Svenne,

I will investigate for you on this issue.


Very strange. Today the Key Commands list is back. However there is still a serious problem. I can edit a “button”, but it won’t “stick”. If I close IC Pro and open it again, the newly edited button is gone.

Well, maybe tomorrow…

Dear Svenne,

I would need some more information from you, to continue on this matter. Are you using an iOS (Apple) or Android device? And is it receiving an automatic IP number by your router or did you assign a static IP number ?

Thank you!

I use iOS. I believe that I use an automatic IP number… At least I don’t recall entering an IP number manually, when I installed IC Pro.

Anyhow, it seems to work now. With the exception that new buttons are gone the next time IC Pro is launched. I have 8 pages full of button, that I’ve made and that still are there after a relaunch. It’s just newly added buttons that won’t “stick”. Any idea what can be causing this?

While writing this, another problem appears. I tried programming a new button, closed IC Pro and reopened it, all while Cubase remained active. This time all the faders (and everything else in connection with the open project, it appears) was gone!

I closed IC Pro and Cubase…and Cubase won’t quit! It had to be Force Quit! I relaunched Cubase and IC Pro. Still no faders in IC Pro! As a last resort I tried disconnecting IC Pro and reconnecting it. Now the faders appeared again, and Cubase seems to quit correctly.

This isn’t the first time I’ve experienced strange behavior from Cubase/IC Pro. When I connected a second monitor to the computer, SKI Remote disappeared from Cubase and had to be installed.

IC Pro tripped me up by complaining that there was no computer. This seemed strange since there clearly was and the wi-fi network worked perfectly with everything else! Steinberg should really change this error message. That IC Pro can’t find ant Cubase installation with SKI remote available is not the same as there being no computer! It should read that IC Pro can’t find SKI remote.

Then the SKI remote installation would be at the top of the list of possible causes. Now, I wasted hours trying to figure out was wrong with the network. That the SKI remote plug-in would be erased from Cubase, just because a second monitor was connected, never entered my mind. I was pure coincidence that I noticed that it was missing in the Device Setup.

Dear Svenne,

Thanks for your info… are you familiar with setting up a static IP number for your device within your router? In some cases that has solved the issue.


Thanks for your suggestion. However, I’m not sure that it’s viable solution. my ISP requires that I use a dynamic IP (if I’m not prepared to pay lots of money for a static one), and I’m not prepared to give up my Internet connection.

I have used IC Pro for months, without any problems at all. These started when I switched from a VDSL to a Fiber connection a couple of weeks ago. This necessitated that I replaced my (Thompson) ADSL modem/router with a another (a TP-Link) router.

I can understand how the problem with the faders and “project view” disappearing in IC pro can make you suspect that the IP number as the cause. However, let me point out that even when the faders disappears, the Transport buttons and the KC buttons, in IC Pro, work as expected. If the IP was the cause, wouldn’t IC Pro stop working all together (and give me a “No Computer” error). It doesn’t! Disconnecting it and reconnecting it restores the faders. Closing and Relaunching doesn’t.

It appears that IC Pro “looses connection” with the project (has trouble “reading” it), not with Cubase as such. This leads me to believe that the cause is likely to be with the the SKI Remote.

That IC Pro lost connection with Cubase when I added a second monitor, had nothing at all to do with IP numbers. It was caused by the SKI Remote being erased on the computer, when a monitor is being added.

With regard to the second problem, that newly created the KC buttons disappears when IC Pro is relaunched. I find it very hard to see that this has anything to do with IP numbers. Aren’t these settings stored on the iPad?

Dear Svenne,

thanks for your answer. I am only referring to your internal LAN. Your router will assign an IP number to each device in your network, usually something like 192.168.1.X… please give this a try and set up your device to manual. This will not change the dynamic IP by your provider for your internet connection.

Thank you!