Missing Midi velocity

So, using Cubase 10.5 Pro, I built a drum track in Groove Agent 5. I then decided to append the track with a crescendo of cymbals. However, while Groove Agent may well be able to do that, it’s a bit beyond my capabilities, at this point in time. Consequently, I played the cymbals on my E-drums and captured the data in Cubase. All looked fine, till I played the track back and found there was no velocity accompanying the cymbals notes; only a final kick drum beat shows its velocity, and plays? Initially, I thought there might be a disparity between Cubase and my Alesis E-drums, but both Crash and Ride appear assigned to the right notes; C# and D# respectively. What I would like to know, if anyone can help, is there a way of adding velocity in Cubase, to resolve the situation?

Thanks, Geoff Emm

Just go into an editor and make sure velocity is selected st the bottom. You can then change it for any note recorded by pulling the bars up or down. It would probably be easier to use the drum editor. Do you know it is velocity as since you don’t know how to adjust it how can you see it? I say this as even in drum editor the velocity of each hit is at the top as well when you select the hit. Are you sure you haven’t just not mapped the notes correctly? Also if you don’t want to change the notes on the module or groove agent the drum map allows you to change the out note so you can come in on one note and send midi out on another.

Thanks for your response and time; I should have responded sooner, I know, but have been tied up with the song. Sorry. Anyhow, I’ve a feeling I didn’t make my issue very clear? The fact is, having gone into the drum editor, I found there were no velocity bars to adjust, except for the very last note in the sequence, which was a kick drum hit? And the fact that the kick had velocity and the cymbals didn’t, and both had been created in the same sequence by the same source, the Alesis, caused me to think it was a configuration problem. Having said that, I resolved the issue by copying the midi data from the Alesis recorded Cubase track and pasted it into the Groove Agent track. Job done!
Thanks again, Geoff Emm


If there was no Velocity, then the Velocity was probably set to 0 or 1, so you didn’t see it. By default settings, you can see the Velocity also by the color of the “diamond”. Red is high velocity, blue is low velocity.

Thanks for that Martin. So, I’m assuming that prior to recording, the velocity would be set in the ‘Inspector,’ window?
Geoff Emm


No the Velocity in the Inspector has nothing to do with the Velocity of every single MIDI Note. In the Inspector, you set the Volume of the MIDI Channel in case of the MIDI Track, or the Volume of the Instrument (Audio Return of the Instrument) in case of the Instrument Track.

Ah, got it! Thanks.
Geoff Emm