Missing new lines (Dorico 3.1)

Just updated to 3.1 (great work, guys!), but I have an issue with the new lines.

Some of them are missing in the new Lines side menu, and even if I try to create one of those by any method, they just don’t appear in/on/over the staff.

Any ideas on how to solve this?

Just to get the obvious question out of the way: have you restarted your computer since updating Dorico?

Yes, that was my first idea :slight_smile: Maybe uninstalling and downloading again? Should not be an issue with license, right?

It won’t be a license issue. It’s not something that anyone else has reported, to the best of my knowledge, so I’m somewhat out of ideas.

I would guesss it’s a font problem. Are you on Windows or Mac?

Yes, that’s definitely a font problem of some description. Check that you don’t have an outdated version of Bravura installed on your computer. Check all of the font locations (on macOS there are two important ones: the one in /Library and the one in ~/Library).

Problem persists. Not that I NEED those lines missing right now but I don’t want my program begin to do some weird things if I leave this issue unattended. Here is what I’ve tried:

1. Uninstalling and reinstalling Dorico Pro 3
I run it and open some files. Same lines are still missing.

2. Downloading Bravura fonts again
Googled them and got here: https://github.com/steinbergmedia/bravura/tree/master/installers/mac
and didn’t know what the “.pkcgproj” files were for, they seem to only open online and not being downloadable.

So, i went back to here: https://github.com/steinbergmedia/bravura/tree/master/redist
and downloaded all .eot, .otf, .svg and .woff files. My Mac seems to recognize only the .otf ones. I remove old copies in the Font Book and install the ones I just downloaded. While installing BravuraText.otf I get a warning about “problems with some fonts during validation”, about “name table usability”. I proceed to install anyway.

Run Dorico and open some files again. Same lines are still missing.


Is there something I’m still doing wrong?
BravuraText OTF warning.jpeg

You don’t need to have Bravura installed in your Mac’s fonts folders at all. It’s already contained within the application package. So remove Bravura and BravuraText from both /Library/Fonts and /Users/your-username/Library/Fonts, then try running Dorico again.

Same results (Bravura fonts were not in /Library/Fonts, but only in /Users/-username-/Library/Fonts; I removed them all the same).

Ran Dorico, uninstalled and installed it yet again but problem persists. Lines missing are “Wavy”, “Wavy narrow-wide” and “Wide wiggly”, for all it could help.

I begin to think is an issue with my OS. I’ll update it ASAP, but if there’s any help you guys can provide me, it’ll be more than welcome.

Try navigating to /Users/your-username/Library/Application Support/Steinberg/Dorico 3. In that folder you should find a file called userlibrary.xml. Drag that out of there (e.g. move it to your desktop), then run Dorico again. If you start a new project, do all the lines appear in the right panel?

Upgrading your version of macOS is unlikely to have any bearing on this problem, so hold fire before you contemplate such an extreme way to try to fix this. Be patient and we’ll certainly figure it out in the end.

@pianoleo; There’s no such file, not only in that folder but in my Mac. (!)
@Daniel: I truly appreciate your comment. The commitment you guys show with the forum is what makes Dorico user community so unique.

As I said before, I don’t NEED those lines right now, I’m in no hurry to solve this minor issue. I’ll be aware of any way out of this anyway.

Thanks a lot!

Bernardo, if you run Font Book, please verify that Bravura does not appear as an installed font on your system.

There were two: Bravura and Bravura Text. I just removed them both. Lines are still missing :frowning:

UPDATE

After deleting Bravura fonts in Mac’s Fontbook, I uninstalled and installed Dorico again, problem solved!

You guys have just got a user for life. Thanks a lot. Greetings from Mexico City.

Pleased we finally got to the bottom of it, Bernardo!

Like in a bad, bad horror movie franchise, those lines are missing again in my Dorico.

I have already done what I did last time (deleting Bravura fonts from Mac’s Font Book, uninstalled an reinstalled Dorico), but problem has creeped in again.

Any ideas you can come with will be welcome. I’m updating Mac’s OS just in case.

Does Font Book now show any installed copies of Bravura on your system, Bernardo?

Yes, both Bravura and Bravura Text.

Can you try opening a Terminal window and executing these commands, then copy and paste the output into a reply here?

ls /Library/Fonts/Brav*



ls ~/Library/Fonts/Brav*

We’ll get to the bottom of this in the end, fear not!

Thank you, sir!

Here’s the response I got. (“Climaxsonico” is my user name since teen, please don’t judge me too harshly.)
Mac Terminal Bravura fonts.jpeg