Missing piano in score, even when music appears in part

I am working with a full score imported from an XML file, and the piano is not showing up in any view. The part is complete and the music shows up when the part is selected. I have included a screenshot here showing the score in Setup mode, which also shows that the proper box is checked for the piano to appear in the flow.

What wisdom from the Oracle?

The break at the start of the flow is indicating that you have manually set staff visibility.

Also make sure that the piano is correctly assigned to flows and layouts by selecting just that piano player and checking which flows and layouts are highlighted in the bottom and right panels.

1 Like

Thank you , Lillie, but I checked that first, and the piano part isn’t even listed as an option to appear or not.

The piano indicates that it plays in every flow, and the piano part itself is complete but invisible everywhere else.

Most mysterious.

Something came up the other day with similar symptoms (albeit you’d need to check in the score, not the part). See Percussion part does not show, even though it is in the score - #4 by pianoleo

Does that help?

A good suggestion, which I will remember for another time, but Flows and Players are set to All.

The strangest thing is that the music clearly exists in the piano part, the player and layout are listed in Setup mode, but its visibility is deactivated somewhere so that it doesn’t show up anywhere else.

I also noticed that the instrument is greyed out in the Mixer panel, along with the other instruments that don’t appear in this particular flow.

Can you attach the project itself here so we can take a look at it?

Happily: https://drive.google.com/file/d/1tiTGu-KaHxl62OaftsnX1GsqufJeq07d/view?usp=share_link

Can you change the link to provide public access, i.e. without requiring a password?

Oh for Pete’s sake. Access granted! Sorry about that…

I do not see a Dorico file in the linked folder.

The problem here is that the Piano player is not included in the Full Score layout.

  1. go to Setup mode
  2. select the Full Score layout in the Layouts panel
  3. click on the checkbox for the Piano player in the Players panel
2 Likes

Well, for goodness sake. Seemed like I checked all combinations of part inclusion, but I missed that one.

Many thanks, all!

David, you only need to check one thing:
Is my player included in my Layout?