Mix Console Craziness

  1. I select Channel 1 in the mix console.
  2. I click on the Channel 2 fader with my mouse and move it.
  3. Channel 1 is still selected in both the arrange window and the mixer console.
  4. I press ‘M’ on my keyboard to mute the selected channel.

Which channel would you think gets muted? Wrong :slight_smile:. Channel 2 gets muted.

I’ve been hunting for a preference to disable this behavior, but haven’t been able to find anything. Anybody have any ideas?

Hi,

The red frame indicates the focus (not the selection). The red frame moves to the Channel 2 once you move the fader. Then you control Channel 2 via Key Commands. So once you hit M, you Mute Channel 2, where is the focus (red frame).

Yes, I understand. My question is: how do I stop this from happening? I’m looking at the arrange window and see track 1 selected, so I hit “m” and expect the selected track to be muted. It makes no sense to have a separate focus track from a selected track. If I move a fader by any other means, for example by my control surface or the mouse wheel, the focus doesn’t change.

Hi,

You cannot stop this. Event hough you are looking at the Project/Arranger window, the focus is still in the MixConsole.

Same as if the focus is in the Project/arranger window (upper part) and your Key Editor is open (and MIDI Notes are selected) and you are looking to the Key Editor. Then you press the key arrow up on your computer keyboard with expectation the MIDI Note will transpose. But it will not, the focus is in the arranger area. Sorry, Cubase doesn’t know, where you are looking to.

I have to admit, I have the very same problem too here on my side (mostly the one with the Key Editor, I just described). I would wish, Cubase knows where am I looking to. :slight_smile:

Cubase doesn’t need to know where I’m looking. The concept of a mixer channel focus which is separate from channel selection makes no sense, serves no purpose, is inconsistent with fader movement by other means, and causes confusion. It should be eliminated :slight_smile:.

+1

Workaround
Create a Project Logical Editor Preset that toggle mute states for selected tracks.
Set the shortcut key for it.
(In Preferences, “Sync Selection in Project Window and MixConsole” is on.)

Hi,

Good idea.

Very clever!

Unfortunately, this doesn’t also mute any tracks linked to the selected track. Do any logical editor wizards out there know how to fix that?

This is a great workaround!
Creating two Project Logical Editor Presets, one for solo and one for mute, and subsequently assigning the original key commands to them worked like charm.

This problem drove me crazy when trying to toggle solo for two selected tracks in order to do A/B comparisons; see thread https://www.steinberg.net/forums/viewtopic.php?f=286&t=163414. Any level or other change in the mix console would make the ‘S’ or ‘M’ key affect the most recently manipulated track rather than the selected tracks…

Steinberg really should have addressed this in a bug fix; I presume the issue still exists in 10.5. It doesn’t matter how you put it, there should at least be an option to disable the default behaviour. (I regard it as a bug myself.)

I hope no one minds me reviving a dormant thread, but…

As a person relatively new to Cubase,
What is the difference between track selection and track focus? My guess is that focus is for when you’re using the QWERTY keyboard to control parameters. That’s the red frame. Isn’t that the same as keyboard focus?

Track selection is for when you want to do some operation or edit on one or more track. It’s indicated by the gray. But tracks also go gray when I use the corresponding fader Or track select button on my control surface.

To add to the confusion, there is mouse focus. If I hover Mouse over a particular fader on the mixer, I can then adjust the level using the scroll wheel. However the track is not gray, so it is not selected.

So it’s possible to have selection, keyboard focus, and mouse focus on three different tracks at once.

Am I on the right track? (Pun not intended)

Hmmm…