Mix to Mono stuck in Elements "Normalize" function

I noticed in Elements Normalizing a mono file will always produce a new file if “Mix to Mono” option is selected.

The strange thing is, when working with Mono files, this option cannot be deselected (is greyed out!)

You have to get back to a stereo file, open the Normalize panel and select Stereo Link. Then go back to your Mono files.

I hope I was clear.

WaveLab can’t change a stereo file to a mono file without openening a new window.
Concerning the second remark, the check box is checked but since it is disabled, it is meant to have no efffect. But this is not the case. I have to fix that. Thanks for the report.

Thank you so much PG!