MixConsole: selected tracks not respected when using mute/solo key commands

When using the key commands for inverting mute/solo (m/s) from within the MixConsole, I expect the mute/solo status of all selected tracks to be affected. However, it either will invert the status only for the first selected track or the track that was last interacted with from within the MixConsole window.

I have created a short video that shows the issue starting with an empty project: http://www.power-xs.net/opcode/temp/MixConsole-mute-solo.mp4 (sorry for the poor audio; it’s very quiet, please turn it up)

In my opinion, there should at least be a setting that will allow me to have all selected tracks affected (especially when track selection is configured to be synchronised in settings), because otherwise one cannot freely switch between the project window and the mix console whilst inverting mute/solo in order to do A/B comparisons, for example.


Please follow this thread. I believe this is the same, right?

Hi Martin,
I think you may have mixed up the link. (It points to an Apple support page.)
Did you mean this one?

Hey opcode, I’m also really frustrated by this behaviour.